Minimize / Maximize from Docky not working on all applications

Bug #317908 reported by James Schriver on 2009-01-16
Affects Status Importance Assigned to Milestone
Jason Smith

Bug Description

Minimizing / Maximizing applications from Docky fails to work on certain applications (Brasero, Epiphany, Evolution). I'm using 0.8 branch rev. 855 on Ubuntu Jaunty x64. I included a video as an example. If run is clicked from the launcher GNOME-Do crashes.

Jason Smith (jassmith) wrote :

Can i get a backtrace from this crash? run do as "mono --debug /usr/lib/gnome-do/Do.exe"

James Schriver (dashua) wrote :
James Schriver (dashua) wrote :
Jason Smith (jassmith) wrote :

I am very compelled to offer up wnck as the problem here. I can of course stop the crashing, but I dont think I can make it work. Wnck seems to think you dont HAVE an active workspace at all...


James Schriver (dashua) wrote :

Ok, the crashing is gone now from right clicking the launcher and either using run or selecting the open application. Minimizing / maximizing is still sporadic with the same wnck error when clicking the launcher to activate a minimize or maximize action. Thx.

James Schriver (dashua) wrote :

Pulled libwnck from trunk, rebuilt do ,and still the same workspace issue.

Jason Smith (jassmith) wrote :

can you stop by on #gnome-do on We need to talk live.

James Schriver (dashua) wrote :

Sure, I'm idliing in there most of the time. Just ping my nick dashua on when you're available. Thx.

James Schriver (dashua) wrote :


I disabled Compiz (git master) and enabled compositing via Metacity and the minimize / maximize issue seem to have been mitigated. Although, I am still testing as for why Compiz may be causing this issue, I am still receiving this error under under Metacity (epiphany-browser:5920): GLib-CRITICAL **: g_hash_table_unref: assertion `hash_table != NULL' failed.

>(epiphany-browser:5920): GLib-CRITICAL **: g_hash_table_unref: assertion `hash_table != NULL' failed.

This is from the Epiphany instance you ran from Do (all the
applications you start log to the same terminal as Do). This message
has nothing to do with Do.

James Schriver (dashua) wrote :

This definitely seems to be an issue related to Compiz. I uninstalled from git master and reinstalled the Jaunty packages and the issue seems to be gone. I'll continue to monitor the situation and post accordingly. Thx.

Minimize/Maximize works fine on my configuration with Compiz.

However, Docky does not minimize GIMP toolboxes.

$ dpkg -l gnome-do* | grep ii
ii gnome-do 0.8.0-0~intrepid~ppa1 Quickly perform actions on your desktop
ii gnome-do-plugins Extra functionality for GNOME-Do launcher
ii gnome-doc-utils 0.13.1-0ubuntu1 a collection of documentation utilities for

This is a GIMP option, you need to change how gimp handles the window
manager inside of the gimp preferences.

--Alex Launi

@Alex: works great ! Thanks

I just came across something which I think is relevant to this.

I was having this very problem with Firefox and Docky only. It would minimise Firefox, but would not maximise it. I realised that I had focus prevention set in compiz to "very high", but the string associated was set to apply this only to the main Firefox window*.

As soon as I turned focus prevention off entirely, I had no more problems minimising and maximising with Docky.

* On a note of possible amusement, the reason I set this up was because I frequently want both Pidgin and Firefox open when I log in to this laptop. When I started using GNOME-Do (sans-Docky), it made opening them so quick that Firefox would often load, stealing focus, as I was typing my password into Pidgin. Since Do and Docky are quite important to the way I use my desktop, I'm solving this for now (an possibly forever, since this idea makes more sense) by setting the Pidgin password windows to be always "Always on Top".

Jason Smith (jassmith) on 2009-02-07
Changed in do:
assignee: nobody → jassmith
importance: Undecided → Medium
milestone: none → 0.8.1
status: New → Fix Committed
James Schriver (dashua) wrote :

This bug is still not resolved 100% with Compiz git master I'm running Jaunty 64 with Docky from trunk (r947) and Compiz git master. The minimize/maximize issue seems to be resolved, but upon initial lanch of an application from Docky, upon minimizing for the first time, the window disappears off the screen in the upper right corner instead of minimizing back to the dock. It only does this once as once the application is docked you can minimize/maximize as many time as your heart so desires. Screencast attached depitcing the issue.

James Schriver (dashua) wrote :

I'm still inclined to believe this a Compiz master bug. It happens while using AWN, just not nearly as frequently. Hrm.

Alex Launi (alexlauni) on 2009-04-22
Changed in do:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers