Do

Unable to change Docky background color via Preferences

Bug #316978 reported by Chris Hollenbeck on 2009-01-14
50
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Do
Medium
Jason Smith

Bug Description

The Appearance tab in GNOME Do Preferences has a Background Color selector for the Docky theme. I am able to open up the color dialog and select a new one, but closing the Preferences window does not apply the new color. When I re-open the Preferences window, the Background Color has reset to the previous color.

Related branches

lp:~alexlauni/do/color-config
Rejected for merging into lp:do/0.8
Do Core Team: Pending requested 2009-01-18
Ding Zhou (tualatrix) wrote :

I have the same problem.

Florian M. (flomar) wrote :

I can confirm this too - 0.7.95.1 (testers ppa)

Alex Launi (alexlauni) wrote :

You are not supposed to be able to change the colour, but we should disable the control.

Changed in do:
importance: Undecided → Low
milestone: none → 0.8
status: New → Confirmed
Alex Launi (alexlauni) wrote :

I thought we had talked about this in irc at one point and decided against
it. I don't care either way I was just reiterating what I had remembered
discussing a while back.

--
--Alex Launi

Ok, let's disable the color switcher for Docky. But we need to make it
not reset itself to opaque black all the time.

Patrick Ulbrich (pulb) wrote :

i'd like to specify a different bgcolor too. my desktop has a relatively dark background so i need to specify another bg color for docky. i'd be happy if this would be configurable via gconf :-)

falconmusic (falconmusic) wrote :

The black doesn't match my white theme at all ;)

Miguel Branco (arlanthir) wrote :

+1 for color change instead of just disabling the control!

it looks like in 8.0 the background color changer is still there, and still doesn't work.

Jason Smith (jassmith) on 2009-02-07
Changed in do:
assignee: nobody → jassmith
importance: Low → Medium
milestone: 0.8 → 0.8.1
Otacon1987 (orfeo18) wrote :

Let's Change background color!! CUSTOMIZATION RULEZ! XD

manzur (sl-solaris) wrote :

yeah it rulez!!!!!!!!!!!!!!

Alex Launi (alexlauni) wrote :

We've removed the button, so this isn't valid anymore :)

Changed in do:
milestone: 0.8.1 → 0.8.2
status: Confirmed → Fix Committed
Changed in do:
status: Fix Committed → Fix Released

Please could you make possible to change docky color? I really want to have white semi-transparent docky instead of black, which does not looks good for me..

Changed in do:
status: Fix Released → Incomplete
status: Incomplete → Fix Released
Alex Launi (alexlauni) wrote :

Don't change our bug statuses if you're not a developer. Not cool. Specially when you're wrong.

Changed in do:
status: Fix Released → Confirmed
Robert Dyer (psybers) wrote :

Heh, actually he changed it back to where it was. Probably as an accidental change (those happen often on lp). You actually set it to the wrong status Alex! :-)

Changed in do:
status: Confirmed → Fix Released
Alex Launi (alexlauni) wrote :

I'm gonna make a note that I'm kinda drunk and belligerent

Alex Launi (alexlauni) wrote :

So sorry for getting fussy

Wolter Hellmund (wolterh) wrote :

Why did you settle on not being able to change the background color?? It has no sense whatsoever. How could it subtract goodness from the application, specially when changing the selected items color in the Appearance preference dialog also changes the background color in docky?

All I'm saying is, if the color is customizable in some way, why not make it customizable in the best way, the most accessible to the user and the most rational?

Robert Dyer (psybers) wrote :

a) Why are you replying to a bug that is *over* a year old? 15 months in fact...
b) Why are you arguing about a feature for Docky, on a Gnome Do bug list, when it is not even part of Gnome Do anymore?
c) The new Docky (which is its own, stand-alone application with its own bug system) has theme support and thus you are arguing for something already supported.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers