Do

Thumbnails are never displayed when files have spaces in their names

Bug #311551 reported by Yuzem on 2008-12-26
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Do
Low
Unassigned

Bug Description

Pictures and videos that have thumbnails are shown with a generic icon not even the correct icon for their respective mimetype. Others show the correct icon but no thumbnail and others show the thumbnails as expected.

The problem seems to be random. I have a video named "Grindhouse Trailers.avi" A generic icon was displayed for it. Then I renamed the video to "Grindhouse.avi" and now it displays the thumbnail.
I thought that it was because of the space char but other files with spaces work as expected.

Using version 0.7 in ubuntu Hardy.

Do will display a thumbnail for a file if Nautilus (or some other program) has already created the thumbnail. In your example, the thumbnail did not exist, then you renamed the file (I'm guessing in Nautilus?), the thumbnail was generated, then Do found it. Is this correct?

Yuzem (yuzem) wrote :

No, the thumbnail existed before renaming the file. And this happened with other files too that I know to have thumbnails but they aren't shown in Do. In most of the cases the files that have no thumbnail in Do have spaces in their filenames but sometimes there are files that also have spaces and the thumbnail works.

I know that Do does not generate any thumbnail. The thumbnail must exist before to be displayed in Do. Another strange thing is that many times the files that doesn't show the thumbnail do not show the correct icon for their mime type, instead, a generic icon is displayed.

I am not convinced that the behavior is "random."

Changed in do:
status: New → Incomplete
Yuzem (yuzem) wrote :

I don't think it is random... but It seems random because I don't know exactly under what circumstances it is produced. I think spaces have something to do with it.

Thunar differs from nautilus when enconding the file names. Some special chars are not encoded in thunar while nautilus encodes more chars. Then for example if thunar has generated a thumbnail for a file when exploring with nautilus the thumbnail is generated again because it is not recognized since the md5sum is based on a differently encoded URI.
I thought that that could be the cause but I have tested the same file with the thumbnail generated by thunar and nautilus and the problem persist. Maybe I didn't test it correctly...

I can confirm this bug. Firstly, it's great to see the thumbnails feature; gives Do a whole new level of polish don't ya think? :-)
Here's what I did. I deleted all thumbnails before trying anything. Then I invoked Do and browsed to a folder of videos, which were shown as generic icons, as expected. Then I opened that folder of videos in Nautilus which started thumbnailing them. Browsed again to the folder in Do. The thumbnails were there, but not all of them. As hinted above, all video files with spaces in their names didn't show their thumbnails in Do. All other video files where shown with the proper thumbnails.
Just to be sure, I checked that all the thumbnails were indeed present in the gnome thumbnails directory; they were all there.

So it definitely seems to be a 'spaces' issue.

BTW, great job with the 0.8 Alphas. Was pleasantly surprised to see an update waiting one day. Although, a blog post or sthing about the release, explaining features would be great. I guess that'll be with the final release.

Forgot to mention. I removed spaces from a filename, and Do showed the thumbnail properly (Even though Nautilus didn't regenerate the thumbnail (as it used to, right?)).

Ubuntu 8.10
Gnome-Do 0.7.98.1

Do 0.8.0 and Do-plugins 0.8.0 still has this issue. File actions (move, copy, etc.) are now working fine on filenames with spaces.
Also, spaces anywhere in the path (not just the file's name) prevents Do from displaying thumbnails.

And why is the status still not CONFIRMED?? Nobody able to reproduce this bug??

Chris Halse Rogers (raof) wrote :

I can confirm this; files with spaces don't get thumbnails, files without spaces do.

Changed in do:
importance: Undecided → Low
status: Incomplete → Confirmed
Changed in do:
assignee: nobody → djsiegel
milestone: none → 0.8.1
status: Confirmed → In Progress
status: In Progress → Fix Committed

Hi, just wondering when the latest fixes (including this one) are gonna be released. Was nice to see many other plugin bugs fixed and released in a short time (0.8.0 - 0.8.0.2).

Robert Dyer (psybers) on 2009-07-03
Changed in do:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers