Do

About-button of plugins has broken refers

Bug #282973 reported by klap-in on 2008-10-14
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Do
Low
Alex Launi

Bug Description

Under the list of Plugins in the Gnome Do Preferences window there is an 'About' button. This button refers to the wiki pages with descriptions of the plugins.

Some of the referers are broken by changing links.
Examples:
broken: http://do.davebsd.com/wiki/index.php?title=VolumeControl_Plugin -->> should be: http://do.davebsd.com/wiki/index.php?title=Volume_Control_Plugin
broken: http://do.davebsd.com/wiki/index.php?title=WindowManager_Plugin -->> should be: http://do.davebsd.com/wiki/index.php?title=Window_Manager_Plugin
broken: http://do.davebsd.com/wiki/index.php?title=VinagreVNC_Plugin -->> should be: http://do.davebsd.com/wiki/index.php?title=Vinagre_Plugin
broken: http://do.davebsd.com/wiki/index.php?title=GNOMEScreenshot_Plugin -->> should be: http://do.davebsd.com/wiki/index.php?title=GNOME_Screenshot_Plugin
broken: http://do.davebsd.com/wiki/index.php?title=LocateFiles_Plugin -->> should be: http://do.davebsd.com/wiki/index.php?title=Locate_Plugin

So far I see so quick this are the broken links of the 'Official Plugins'. The other plugins I haven't checked.

A temporary solution is adding redirects to the correct wikipages.
But repair the referers in Gnome Do will be fine.

Related branches

Confirmed with Do version 0.6.1.0-0ubuntu2 in Ubuntu 8.10 (Intrepid).

Changed in do:
status: New → Confirmed

I added in redirects to the listed pages. It looks like not all of the plugins follow the wiki page naming convention. Is there a specific URL format that should be used to get the About links working consistently? It should be easy enough to add in redirects as required on any remaining pages and move things around from the original to the current redirect page as needed.

Examples of differing locations:
1. http://do.davebsd.com/wiki/index.php?title=DiskMounter_Plugin (works from About, and is the only page)
2. http://do.davebsd.com/wiki/index.php?title=GMailContacts_Plugin (works from About, and is the only page)

Based on some of the existing pages, they should be Disk_Mounter_Plugin and GMail_Contacts_Plugin.

On Thu, 2008-11-13 at 04:07 +0000, Chris Hollenbeck wrote:
> I added in redirects to the listed pages. It looks like not all of the
> plugins follow the wiki page naming convention. Is there a specific URL
> format that should be used to get the About links working consistently?
> It should be easy enough to add in redirects as required on any
> remaining pages and move things around from the original to the current
> redirect page as needed.

After reading the code, for the "About" button to work, the pages need
to be named $id_Plugin, where $id is the value from the addin.xml file.
A current list of these is:

id="Amarok"
id="Archive"
id="Banshee"
id="Cl.ickable"
id="delicious"
id="DiskMounter"
id="Epiphany"
id="Evolution"
id="File"
id="Firefox"
id="Flickr"
id="GoogleCalendar"
id="GoogleDocs"
id="GMailContacts"
id="GNOMEDictionary"
id="GNOMEScreenshot"
id="GNOMESession"
id="GNOMETerminal"
id="GoogleCalculator"
id="GoogleMaps"
id="Google Search"
id="ImageShack"
id="Launchpad"
id="LocateFiles"
id="ManLookUp"
id="OpenSearch"
id="Pastebin"
id="Pidgin"
id="Rhythmbox"
id="Riptide"
id="RSS"
id="Shelf"
id="Tasque"
id="Text"
id="Tomboy"
id="Twitter"
id="VinagreVNC"
id="VolumeControl"
id="WindowManager"

Robert Dyer (psybers) wrote :

What is the status of this, has anyone verified they do/dont work right now?

Changed in do:
importance: Undecided → Low

I just went through all of them in version 0.8.1.3. The following pages are still broken:

Cl.ickable WebClips -> http://do.davebsd.com/wiki/index.php?title=Cl_Plugin
ClawsMail -> http://do.davebsd.com/wiki/index.php?title=ClawsMail_Plugin
Google Search -> http://do.davebsd.com/wiki/index.php?title=GoogleSearch_Plugin
JIRA Integration -> http://do.davebsd.com/wiki/index.php?title=JIRA_Plugin
Music Player Daemon -> http://do.davebsd.com/wiki/index.php?title=MPD_Plugin
NX -> http://do.davebsd.com/wiki/index.php?title=NX_Plugin
Opera -> http://do.davebsd.com/wiki/index.php?title=Opera_Plugin
Ping.FM -> http://do.davebsd.com/wiki/index.php?title=PingFM_Plugin
Putty -> http://do.davebsd.com/wiki/index.php?title=Putty_Plugin
Quote -> http://do.davebsd.com/wiki/index.php?title=Quote_Plugin
Read Manual Pages (man) -> http://do.davebsd.com/wiki/index.php?title=ManPages_Plugin
Riptide -> http://do.davebsd.com/wiki/index.php?title=Riptide_Plugin
Simple RSS Reader -> http://do.davebsd.com/wiki/index.php?title=RSS_Plugin
Skype -> http://do.davebsd.com/wiki/index.php?title=Skype_Plugin
SqueezeCenter -> http://do.davebsd.com/wiki/index.php?title=SqueezeCenter_Plugin
StockQuote -> http://do.davebsd.com/wiki/index.php?title=StockQuote_Plugin
System Services -> http://do.davebsd.com/wiki/index.php?title=SystemServices_Plugin
Terminal Server Client -> http://do.davebsd.com/wiki/index.php?title=TerminalServerClient_Plugin
Text -> http://do.davebsd.com/wiki/index.php?title=Text_Plugin
Thunderbird -> http://do.davebsd.com/wiki/index.php?title=Thunderbird_Plugin
Tracker Search -> http://do.davebsd.com/wiki/index.php?title=TrackerSearch_Plugin
Translate -> http://do.davebsd.com/wiki/index.php?title=Translate_Plugin
Woof! (Web Offer One File) -> http://do.davebsd.com/wiki/index.php?title=Woof_Plugin
YouTube -> http://do.davebsd.com/wiki/index.php?title=YouTube_Plugin
Zim -> http://do.davebsd.com/wiki/index.php?title=Zim_Plugin

It might just be easiest to go through and create the wiki pages. At least adding in some sort of base template would be more reassuring than a message about the page not having been created. I didn't go through and see if pages for the 'broken' plugin links currently exist with a different title.

Alex Launi (alexlauni) wrote :

The addin description supports a URL attribute, we can use this to set wiki urls.

Changed in do:
assignee: nobody → Alex Launi (alexlauni)
milestone: none → 0.8.2
Alex Launi (alexlauni) on 2009-06-25
Changed in do:
status: Confirmed → Fix Committed
Changed in do:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers