Do

Aliases text items are not saved

Bug #274572 reported by Mandx on 2008-09-25
64
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Do
Low
Unassigned
gnome-do (Ubuntu)
Low
Unassigned

Bug Description

I have defined an alias for launching a command (with command-line parameters) but, Do doesn't show its alias. But, when I retype the command again, appears the "Delete Alias" command.

I'm using GNOME Do 0.6.0, straight from your repo

GreySim (greysim) wrote :

I can confirm this on Do 0.6.1 using the Do Intrepid repo. The alias will work for the session, but as soon as Do is restarted, the alias stops showing up as an option. In this case I'm aliasing "Tango Palette.svg" by going to a folder defined in "Files & Folders", right-arrowing into the subdirectory that the image is inside of, selecting the image, and assigning the alias "Tango Palette" which will work for the rest of the session, using "Palet" as the trigger in my case. Restarting Do, "Palet" comes up with no results. If I manually drill down to the image again though, Delete Alias is one of the actions I can perform on it.

Jason Smith (jassmith) wrote :

This is a known flaw with aliasing. We have to find a way to support these temporary items

Michael Rooney (mrooney) wrote :

Okay, I'll add this to Ubuntu and Confirm it; I can duplicate it as well.

Changed in gnome-do:
importance: Undecided → Low
status: New → Confirmed
status: Confirmed → Triaged
Changed in do:
status: New → Confirmed
rodion (e2k5) wrote :

Can confirm this for 0.8.1. Alias works in the session it was assigned, after a restart off Do it's gone.

kkk (kknull0) wrote :

same problem with 0.8.1.
aliases work only the first time, and don't work in the same session or after a restart.

Isaac Bowen (isaacbowen) wrote :

Same on Jaunty, 0.8.1.3. Hooray.

Isaac Bowen (isaacbowen) wrote :

Workaround: add the custom command as a launcher in gnome-panel's application list (right-click app menu, "Edit Menus", add launchers slash items as needed). Wait a tick for it to gnome-do to pick up on the addition.

Suboptimal, but it works well enough.

Robert Dyer (psybers) on 2009-06-18
Changed in do:
importance: Undecided → Low
vehka (heikki-wilenius) wrote :

Same problem with 0.8.2. Assigning alias works, then as it displays the alias after successful assignment, it works by pressing enter one time, but after that, no more. There isn't even an option to delete the alias.

R. Rigaud (raph-rigaud) wrote :

Gnome Do would be so awesome if this "Alias Plugin" could work properly...
Now, I just can't use it to launch web app.

For example :
chromium-browser %u --app="http://www.google.com/calendar/render"

It would be so good if I could create an "agenda" alias on it... Please, fix this bug.

Thanks a lot.

i'm using ubuntu 9.10 with gnome-do 0.8.3.1 and this happening me too. but, it doesn't save any alias at all. after i hit enter, the alias disappear.

Youarefunny (ktcox) wrote :

Same Here
works for a session but then fails on me.

Wei Ribao (rbwei) wrote :

It looks like this bug re-appears. Worked fine in previous version.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers