Do

default keyboard layout on gnome-do open is unpredictable

Bug #242221 reported by codesnik on 2008-06-22
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Do
Low
Unassigned

Bug Description

in gnome, when you have more than one keyboard layout, and use option "separate layout for each window" in "system" > "preferences" > "keyboard" > "layouts", it would be much more natural to either remember last GnomeDo layout between invocations, or (even better!) just use "system default" one, selected in preferences dialogue mentioned above.

Unfortunatelly, gnomedo window under Gnome opens with the same layout as in window which had focus before I press "super+space", and for me it looks like almost random layout: I have permanently selected English layout in my editors and browser, but Russian layout in my Pidgin, and from both i would want to run the same actions, but in second example i have to switch layout, and i notice that only after several typed letters. Annoying.

  • unnamed Edit (103 bytes, text/html; charset=ISO-8859-1)

Please provide more detail. I am totally unfamiliar with per-application
keyboard layout settings.

codesnik (aronaxis) wrote :

just try it.

"system" > "preferences" > "keyboard" > "layouts"

press "add" and add, say, "french" to the list.

now check "separate layouts for each window"
and click on radiobutton near "USA" layout, so it'll become default.

now add "Keyboard indicator" applet to main gnome panel, just to monitor what's going on. you can switch layouts clicking with mouse on that applet for test purposes, assigning a hotkey for this isn't trivial.

in that mode each window remembers it's own state of keyboard layout, and this is very handy. I start an application, and switch a layout in it only once: I chat mostly in russian, but programming and shell is in english. When I alt-tab between windows, layout is switched according to what was last one for that window.

now you can assume that when launching new windows, they would have a "default" layout preselected. Unfortunatelly, this isn't true in Gnome. newly opened windows, even if they are from other applications, "inherits" _current_ layout. A little misconception in Gnome.
This is of a little annoyance in long running apps, but when using GnomeDo, opening and closing window so often, and typing bursts of keystrokes.. it become frustrating.

so basically fix for that would be
a) check that system has more than one layout, and "/desktop/gnome/peripherals/keyboard/general/groupPerWindow" in gconf is true
b) either remember last layout state on gnomd-do close/applaunch/etc, or (better) just checkout

"/desktop/gnome/peripherals/keyboard/kbd/layouts" array (comma separated string?) and on gnome-do window open event switch to layout, identified by "/desktop/gnome/peripherals/keyboard/general/defaultGroup" number, or 0 if it's not defined,

such a launcher should be usable without checking what is current layout - just a burst of keypresses in a blink of eye and you're done.

Fred Dubois (duboisfb) wrote :

I agree with codesnik, this is an irritant.

I use USA layout for coding and general use, but french layout for chatting and sometimes Firefox. When am chatting and I launch a new terminal, the layout is in french and '/' is replaced by 'é', '~' == '|', etc. Very inconvenient.

It would be better if, like codesnik said, applications would remember the last layout used, or set default layouts for certain applications, or something along those lines.

Is this still an issue with GNOME Do v0.6.1 or later?

Changed in do:
status: New → Incomplete
codesnik (aronaxis) wrote :

v0.6.1.0, remembers it's own layout.
nice!

Changed in do:
status: Incomplete → Fix Released
Oren_B (oren.barnea) wrote :

On my machine this problem still happens (or happens again?) with Gnome Do 0.8.1.3 on Ubuntu 9.04.

Eyal Wiener (eyalw) wrote :

This bug is still alive on Ubuntu 9.04 and Do 0.8.2

Its so annoying... please kill it ! :)

Daniel Rozenberg (daniboy) wrote :

I can confirm that this still happens with the same versions as Oren.

Fred Dubois (duboisfb) wrote :

Confirmed, "bug" still present with Ubuntu 9.04 and Gnome Do 0.8.1.3

Robert Dyer (psybers) on 2009-08-04
Changed in do:
status: Fix Released → Confirmed
importance: Undecided → Low
Andrey Andreev (andreev00) wrote :

I face this bug with Ubuntu 10.04 and Gnome Do 0.8.1.3

Guys, it is a really annoying thing, please do something to let Do remember its own layout. Or probably to use the system default one. I have to switch layouts a few thousands times per day due to this bug.

Linux Mint 12 Lisa, Cinnamon, Gnome Do 0.8.5

The bug is still here. Very sad that such a great program has such an annoying bug. Please fix it.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments