Tomboy opens a new instance with gnome-do

Reported by mandingo on 2008-04-07
8
Affects Status Importance Assigned to Milestone
Do
Undecided
Unassigned

Bug Description

I usually have Tomboy (v 0.10.0) running in my panel, however when I start gnome-do it seems to open a new instance of Tomboy (see attached screen shot).

mandingo (extremeavantgarde) wrote :
Murat Gunes (mgunes) wrote :

I experience the same behavior with 0.4.0.1 in Ubuntu Hardy.

Jorge O. Castro (jorge) on 2008-06-09
Changed in do:
status: New → Confirmed
sojusnik (gelassen) wrote :

Same here.

Because of this bug I reinstalled hardy. The new installed Ubuntu went fine, the tomboy gnome applet and gnome do did well, but after I installed via synaptic the package called "linux-backports-hardy" and rebooted the system, another instance of tomboy appeared in the system tray, so that now I have an gnome panel applet tomboy instance and a system tray tomboy instance. That's really annoying. Of course I tried to remove the previous installed package, but the problem with the tomboy plugin stayed.

I've used gnome-do for 6 months with the appropriate tomboy plugin and everything worked fine, but since 2-3 weeks I started to experience the above mentioned problem with the tomboy plugin...

This is fixed in gnome-do 0.5.97.

The work-around, by the way (for those stuck with old Do), is to run Tomboy in the notification area, and not as a panel applet.

sojusnik (gelassen) wrote :

Hi,

Well, it's fixed only to a half.

I'm using now the 0.5.99 version and I am not able to search via gnome do from the tomboy panel applet.

To search via gnome do I have to launch tomboy via gnome do, it will start in the notification area, wait a little bit and finally then search through my notes.

In my case I want to search via gnome do in my tomboy panel applet, what is not working right now.

sojusnik: Actually, this should be working perfectly. When running Tomboy in the panel, and using gnome-do, you should immediately have access to the search action and the create new note action. It may take a minute or so before your indexed notes appear in Do, though, if that's what you're looking for.

If things are not working as I've described, then there is something wrong with your Tomboy install, and the panel applet must not be registering itself with dbus. We can troubleshoot that if that's the case.

sojusnik (gelassen) wrote :

Hi,

"If things are not working as I've described, then there is something wrong with your Tomboy install, and the panel applet must not be registering itself with dbus. We can troubleshoot that if that's the case."

I'm using Ubuntu 8.04 64-bit so Tomboy was already installed. I just enabled the applet and started to use it. As mentioned above, now it's not possible for me to search or make tomboy notes via gnome do with the applet. Every help is therefore appreciated.

sojusnik: First of all, it's possible your gnome session is messed up, and you should see if you can reproduce this problem after restarting. Also, let me know if you are accessing your session in any "intersting" way, maybe via a remote X session, etc.

If you still have problems, do this:
Remove Tomboy from your panel. Make sure you have no other instance of Tomboy running. Add Tomboy to your panel. Then show me the contents of ~/.tomboy.log .

sojusnik (gelassen) wrote :
Download full text (5.0 KiB)

Thx for helping!

"Also, let me know if you are accessing your session in any "intersting" way, maybe via a remote X session, etc."
I'm starting my pc in a normal way, nothing worth mentioning.

"If you still have problems, do this:
Remove Tomboy from your panel. Make sure you have no other instance of Tomboy running. Add Tomboy to your panel. Then show me the contents of ~/.tomboy.log ."

Content:

15.08.2008 19:06:20 [DEBUG]: NoteManager created with note path "/home/sojusnik/.tomboy".
15.08.2008 19:06:20 [INFO]: Initializing Mono.Addins
15.08.2008 19:06:20 [DEBUG]: AddinManager.OnAddinLoaded: Tomboy.Tomboy
15.08.2008 19:06:20 [DEBUG]: Name: Tomboy.Tomboy,0.10
15.08.2008 19:06:20 [DEBUG]: Description:
15.08.2008 19:06:20 [DEBUG]: Namespace: Tomboy
15.08.2008 19:06:20 [DEBUG]: Enabled: True
15.08.2008 19:06:20 [DEBUG]: File: /usr/lib/tomboy/Tomboy.exe
15.08.2008 19:06:21 [DEBUG]: AddinManager.OnAddinLoaded: Tomboy.EvolutionAddin
15.08.2008 19:06:21 [DEBUG]: Name: Evolution Mail Integration
15.08.2008 19:06:21 [DEBUG]: Description: Allows you to drag an email from Evolution into a tomboy note. The message subject is added as a link in the note.
15.08.2008 19:06:21 [DEBUG]: Namespace: Tomboy
15.08.2008 19:06:21 [DEBUG]: Enabled: True
15.08.2008 19:06:21 [DEBUG]: File: /usr/lib/tomboy/addins/Evolution.dll
15.08.2008 19:06:21 [DEBUG]: AddinManager.OnAddinLoaded: Tomboy.PrintNotesAddin
15.08.2008 19:06:21 [DEBUG]: Name: Printing Support
15.08.2008 19:06:21 [DEBUG]: Description: Allows you to print a note.
15.08.2008 19:06:21 [DEBUG]: Namespace: Tomboy
15.08.2008 19:06:21 [DEBUG]: Enabled: True
15.08.2008 19:06:21 [DEBUG]: File: /usr/lib/tomboy/addins/PrintNotes.dll
15.08.2008 19:06:21 [DEBUG]: AddinManager.OnAddinLoaded: Tomboy.BacklinksAddin
15.08.2008 19:06:21 [DEBUG]: Name: Backlinks
15.08.2008 19:06:21 [DEBUG]: Description: See which notes link to the one you're currently viewing.
15.08.2008 19:06:21 [DEBUG]: Namespace: Tomboy
15.08.2008 19:06:21 [DEBUG]: Enabled: True
15.08.2008 19:06:21 [DEBUG]: File: /usr/lib/tomboy/addins/Backlinks.dll
15.08.2008 19:06:21 [DEBUG]: AddinManager.OnAddinLoaded: Tomboy.FixedWidthAddin
15.08.2008 19:06:21 [DEBUG]: Name: Fixed Width
15.08.2008 19:06:21 [DEBUG]: Description: Adds fixed-width font style.
15.08.2008 19:06:21 [DEBUG]: Namespace: Tomboy
15.08.2008 19:06:21 [DEBUG]: Enabled: True
15.08.2008 19:06:21 [DEBUG]: File: /usr/lib/tomboy/addins/FixedWidth.dll
15.08.2008 19:06:21 [DEBUG]: AddinManager.OnAddinLoaded: Tomboy.ExportToHtmlAddin
15.08.2008 19:06:21 [DEBUG]: Name: Export to HTML
15.08.2008 19:06:21 [DEBUG]: Description: Exports individual notes to HTML.
15.08.2008 19:06:21 [DEBUG]: Namespace: Tomboy
15.08.2008 19:06:21 [DEBUG]: Enabled: True
15.08.2008 19:06:21 [DEBUG]: File: /usr/lib/tomboy/addins/ExportToHtml.dll
15.08.2008 19:06:21 [DEBUG]: AddinManager.OnAddinLoaded: Tomboy.StickyNoteImportAddin
15.08.2008 19:06:21 [DEBUG]: Name: Sticky Notes Importer
15.08.2008 19:06:21 [DEBUG]: Description: Import your notes from the Sticky Notes appl...

Read more...

Well here's the problem:

15.08.2008 19:06:21 [DEBUG]: Tomboy remote control disabled (DBus exception): Unable to open the session message bus.

Though I'm not sure why it's happening. I'll dig a bit and get back to you. I may have to set up an Ubuntu VM so it might be a few days (very busy with work, sorry).

sojusnik (gelassen) wrote :

Hi,

Any updates on this topic?

Thanks for the ping; I've been unavailable lately and had forgotten about your issue, since it's not in our bugzilla (sorry!). Adding this to my list of things to do, though I can guarantee I won't have time to look at it until next weekend at the absolute earliest (unless somebody else can reproduce it).

sojusnik (gelassen) wrote :

Even with the new version of tomboy 0.12.0 the problem remains.

Thanks for the update, sojusnik. This really sucks. I just don't have time to set up an Ubuntu VM right now to see if it's something with the package on that distro. Can anybody else reproduce this with Do 0.5.97 or later?

If so, do you also get this message when running Tomboy from the command line?

15.08.2008 19:06:21 [DEBUG]: Tomboy remote control disabled (DBus exception): Unable to open the session message bus.

sojusnik (gelassen) wrote :

Hi,

Yes, I'm getting the same output:

[...]
24.09.2008 17:17:41 [DEBUG]: Successfully found all system tools
24.09.2008 17:17:41 [DEBUG]: Unable to locate 'wdfs' in your PATH
24.09.2008 17:17:41 [DEBUG]: Tomboy remote control disabled (DBus exception): Unable to open the session message bus.
24.09.2008 17:17:41 [DEBUG]: Applet Created...
24.09.2008 17:17:41 [DEBUG]: EnableDisable Called: enabling... True
[...]

sojusnik (gelassen) wrote :

I'm having the problem with gnome-do 0.6.0 and tomboy 0.12.0 on Ubuntu hardy 64-bit.

Christoph Langner (chrissss) wrote :
Download full text (4.9 KiB)

I can reproduce this issue with

 * Ubuntu Hardy Heron 8.04 32-bit
 * Tomboy 0.10.2
 * Tomfox Firefox Addon 1.0.2

So it's more a bug inside tomboy and not GNOME Do...

When i create a tomboy note via Tomfox Tomboy is started within the notification area even though it is allready active as a panel applet. Here's mine ~/.tomboy.log when I add Tomboy to the panel as a applet.

$ tail -f -n 0 ~/.tomboy.log
tail: /home/toff/.tomboy.log: Datei abgeschnitten
27.09.2008 22:16:25 [DEBUG]: AddinManager.OnAddinLoaded: Tomboy.EvolutionAddin
27.09.2008 22:16:25 [DEBUG]: Name: Evolution Mail Integration
27.09.2008 22:16:25 [DEBUG]: Description: Allows you to drag an email from Evolution into a tomboy note. The message subject is added as a link in the note.
27.09.2008 22:16:25 [DEBUG]: Namespace: Tomboy
27.09.2008 22:16:25 [DEBUG]: Enabled: True
27.09.2008 22:16:25 [DEBUG]: File: /usr/lib/tomboy/addins/Evolution.dll
27.09.2008 22:16:25 [DEBUG]: AddinManager.OnAddinLoaded: Tomboy.PrintNotesAddin
27.09.2008 22:16:25 [DEBUG]: Name: Printing Support
27.09.2008 22:16:25 [DEBUG]: Description: Allows you to print a note.
27.09.2008 22:16:25 [DEBUG]: Namespace: Tomboy
27.09.2008 22:16:25 [DEBUG]: Enabled: True
27.09.2008 22:16:25 [DEBUG]: File: /usr/lib/tomboy/addins/PrintNotes.dll
27.09.2008 22:16:25 [DEBUG]: AddinManager.OnAddinLoaded: Tomboy.BacklinksAddin
27.09.2008 22:16:25 [DEBUG]: Name: Backlinks
27.09.2008 22:16:25 [DEBUG]: Description: See which notes link to the one you're currently viewing.
27.09.2008 22:16:25 [DEBUG]: Namespace: Tomboy
27.09.2008 22:16:25 [DEBUG]: Enabled: True
27.09.2008 22:16:25 [DEBUG]: File: /usr/lib/tomboy/addins/Backlinks.dll
27.09.2008 22:16:25 [DEBUG]: AddinManager.OnAddinLoaded: Tomboy.FixedWidthAddin
27.09.2008 22:16:25 [DEBUG]: Name: Fixed Width
27.09.2008 22:16:25 [DEBUG]: Description: Adds fixed-width font style.
27.09.2008 22:16:25 [DEBUG]: Namespace: Tomboy
27.09.2008 22:16:25 [DEBUG]: Enabled: True
27.09.2008 22:16:25 [DEBUG]: File: /usr/lib/tomboy/addins/FixedWidth.dll
27.09.2008 22:16:25 [DEBUG]: AddinManager.OnAddinLoaded: Tomboy.ExportToHtmlAddin
27.09.2008 22:16:25 [DEBUG]: Name: Export to HTML
27.09.2008 22:16:25 [DEBUG]: Description: Exports individual notes to HTML.
27.09.2008 22:16:25 [DEBUG]: Namespace: Tomboy
27.09.2008 22:16:25 [DEBUG]: Enabled: True
27.09.2008 22:16:25 [DEBUG]: File: /usr/lib/tomboy/addins/ExportToHtml.dll
27.09.2008 22:16:25 [DEBUG]: AddinManager.OnAddinLoaded: Tomboy.StickyNoteImportAddin
27.09.2008 22:16:25 [DEBUG]: Name: Sticky Notes Importer
27.09.2008 22:16:25 [DEBUG]: Description: Import your notes from the Sticky Notes applet.
27.09.2008 22:16:25 [DEBUG]: Namespace: Tomboy
27.09.2008 22:16:25 [DEBUG]: Enabled: True
27.09.2008 22:16:25 [DEBUG]: File: /usr/lib/tomboy/addins/StickyNoteImport.dll
27.09.2008 22:16:25 [DEBUG]: AddinManager.OnAddinLoaded: Tomboy.SshSyncServiceAddin
27.09.2008 22:16:25 [DEBUG]: Name: SSH Sync Service Add-in
27.09.2008 22:16:25 [DEBUG]: Description: Synchronize Tomboy Notes to a SSH share
27.09.200...

Read more...

sojusnik (gelassen) wrote :

I have opened two Bug Reports in the Tomboy Bugtracker:

Tomboy issue: http://bugzilla.gnome.org/show_bug.cgi?id=554151

Tomfox issue: http://bugzilla.gnome.org/show_bug.cgi?id=554152

I'm going to follow up on this via GNOME bug http://bugzilla.gnome.org/show_bug.cgi?id=554151 .

The actual bug in GNOME Do was fixed a long time ago so this should be closed.

This really was fixed in Do 0.5.97...other problems described in this bug are probably with Tomboy, ndesk-dbus, or some Ubuntu packaging.

Changed in do:
status: Confirmed → Fix Committed
Changed in do:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.