Do

gnome-do help opens do.davebsd.com, redirects to spam site

Bug #1363589 reported by Michael N on 2014-08-31
264
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Do
High
Unassigned
gnome-do (Debian)
Fix Released
Unknown
gnome-do (Ubuntu)
Medium
Unassigned
Precise
Medium
Unassigned
Trusty
Medium
Unassigned
Utopic
Medium
Unassigned
gnome-do-plugins (Debian)
Fix Released
Unknown
gnome-do-plugins (Ubuntu)
Medium
Unassigned
Precise
Medium
Unassigned
Trusty
Medium
Unassigned

Bug Description

[Impact]

The plugin Help buttons and Do's About link go to do.davebsd.com, which has been acquired by a spam provider.

This upload changes the About link to go to do.cooperteam.net (the current homepage), and points the plugin Help buttons at Launchpad.

[Test Case]

Start gnome-do; type ‘about do’ and hit <enter> to summon the About page. Click on the Homepage link, and verify that it goes to do.cooperteam.net.

Summon gnome-do, type ‘preferences’ and hit <enter> to summon the preferences page. Go to the “Plugins” tab and select any plugin. Hit the “About” button, if enabled. This should not take you to do.davebsd.com (but might do nothing).

[Regression Potential]

This code is only used in the About page and plugin About links, so that's what should be checked. Regressions are unlikely, the most likely regression would be crashes when pressing the buttons.

[Original report]

When clicking on 'help' in the gnome-do preferences, the link opened is "do.davebsd.com/wiki/index.php?title=Using_Do", it redirects several times, opening various spammy sites (gambling, shopping, etc).

The real problem isn't gnome-do per se, but rather that do.davebsd.com seems to have been co-opted.

Michael N (michael-1234) on 2014-08-31
information type: Private Security → Public Security
Michael N (michael-1234) wrote :

This is GNOME Do 0.9 (0.9-1build1), amd64, Linux Mint 17 Qiana ..

If the domain davebsd is lost, then the pkg would need to be patched? Any way to 'fix' the 'help' button?

Changed in do:
status: New → Confirmed
importance: Undecided → High
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-do (Ubuntu):
status: New → Confirmed
Changed in gnome-do (Ubuntu):
importance: Undecided → Medium
Changed in do:
status: Fix Committed → Fix Released
Chris Halse Rogers (raof) wrote :

Fixed upstream in 0.95.2; needs SRUing.

Changed in gnome-do (Ubuntu):
status: Confirmed → Fix Released
description: updated

Hello Michael, or anyone else affected,

Accepted gnome-do into utopic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-do/0.95.1-1ubuntu2.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-do (Ubuntu Utopic):
status: New → Fix Committed
tags: added: verification-needed
Timo Aaltonen (tjaalton) wrote :

Hello Michael, or anyone else affected,

Accepted gnome-do into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-do/0.9-1ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-do (Ubuntu Trusty):
status: New → Fix Committed
Brian Murray (brian-murray) wrote :

Hello Michael, or anyone else affected,

Accepted gnome-do into precise-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-do/0.8.5-2ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-do (Ubuntu Precise):
status: New → Fix Committed

The fix for this bug has been awaiting testing feedback in the -proposed repository for trusty for more than 90 days. Please test this fix and update the bug appropriately with the results. In the event that the fix for this bug is still not verified 15 days from now, the package will be removed from the -proposed repository.

tags: added: removal-candidate
Mathew Hodson (mathew-hodson) wrote :

I tested gnome-do 0.9-1ubuntu0.1 from trusty-proposed.

In the About page, the Visit Homepage link goes to http://do.cooperteam.net/

The Help button in Preferences goes to https://answers.launchpad.net/do

In the Plugins tab, when you click on a plugin then click the About button, the link still incorrectly goes to do.davebsd.com

That needs to be fixed in the gnome-do-plugins source package, so I am adding a task for that and marking this verification-done.

tags: added: verification-done-trusty verification-needed-precise
removed: removal-candidate verification-needed
no longer affects: gnome-do-plugins (Ubuntu Utopic)
Changed in gnome-do-plugins (Ubuntu):
status: New → Fix Released
Changed in gnome-do-plugins (Ubuntu Trusty):
status: New → Confirmed
Changed in gnome-do-plugins (Debian):
status: Unknown → Fix Released
Changed in gnome-do (Debian):
status: Unknown → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-do - 0.9-1ubuntu0.1

---------------
gnome-do (0.9-1ubuntu0.1) trusty-proposed; urgency=low

  * debian/control: Update Homepage: to not point at spam URL. (LP: #1442873)
  * debian/patches/03_fix_website_address.patch:
    - Update help links to not point at spam URL. (LP: #1363589)
  * debian/patches/04_fix_mono_3.0_build.patch
    - Fix the build with mono 3.0 (LP: #1277891)
 -- Christopher James Halse Rogers <email address hidden> Tue, 14 Apr 2015 11:16:10 +1000

Changed in gnome-do (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gnome-do has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-do-plugins (Ubuntu Precise):
status: New → Confirmed
Changed in gnome-do (Ubuntu Utopic):
status: Fix Committed → Won't Fix
Changed in gnome-do (Ubuntu Precise):
importance: Undecided → Medium
Changed in gnome-do (Ubuntu Trusty):
importance: Undecided → Medium
Changed in gnome-do (Ubuntu Utopic):
importance: Undecided → Medium
Changed in gnome-do-plugins (Ubuntu):
importance: Undecided → Medium
Changed in gnome-do-plugins (Ubuntu Precise):
importance: Undecided → Medium
Changed in gnome-do-plugins (Ubuntu Trusty):
importance: Undecided → Medium
status: Confirmed → Triaged
Changed in gnome-do-plugins (Ubuntu Precise):
status: Confirmed → Triaged
tags: added: bytesize string-fix
tags: added: bitesize
removed: bytesize
tags: added: trusty

The fix for this bug has been awaiting testing feedback in the -proposed repository for precise for more than 90 days. Please test this fix and update the bug appropriately with the results. In the event that the fix for this bug is still not verified 15 days from now, the package will be removed from the -proposed repository.

tags: added: removal-candidate

The version of gnome-do in the proposed pocket of Precise that was purported to fix this bug report has been removed because the bugs that were to be fixed by the upload were not verified in a timely (105 days) fashion.

tags: removed: verification-needed-precise
Changed in gnome-do (Ubuntu Precise):
status: Fix Committed → Won't Fix
tags: removed: removal-candidate
To post a comment you must log in.
This report contains Public Security information  Edit
Everyone can see this security related information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.