Files and Folders plugin leaks memory

Bug #746795 reported by Osmo Salomaa on 2011-03-31
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Do Plugins
High
Chris Halse Rogers

Bug Description

Ever since updating to gnome-do-plugins 0.8.3 on Debian unstable I have experienced memory issues where do basically consumes more and more memory until I have to kill it. I have now narrowed down the problem and I can easily reproduce it. It happens when the files and folders plugin is enabled, and doesn't happen when it is disabled. It happens at least when I browse through images with Eye of GNOME (eog). Every time I move to a new image, do consumes several megabytes more memory. Perhaps the files and folders plugin keeps an eye on recent files and there's a memory leak in there somewhere?

Osmo Salomaa (otsaloma) wrote :

Commenting out the callback definition for the recent manager "changed" signal seems to make this problem go away, so you probably have a problem in this callback (or the GetRecentFiles method that it calls). I don't know C#, so I can't tell where the problem could be.

void OnRecentChanged (object sender, EventArgs e)
{
    // We update Files here because this is called on the main thread.
    // We call ToArray so that Files is immutable and safe to enumerate.
    items = GetRecentFiles ().OfType<Item> ().ToArray ();
}

Changed in do-plugins:
importance: Undecided → High
assignee: nobody → Chris Halse Rogers (raof)
milestone: none → 0.9
status: New → Confirmed
Changed in do-plugins:
status: Confirmed → Fix Committed
status: Fix Committed → Fix Released
Osmo Salomaa (otsaloma) wrote :

It would be useful if you could give a link to a commit diff when you close a bug, so that we could see how the bug was fixed. Launchpad is very confusing to navigate, especially to people who don't know your project's branch structure. I looked for the commit, but didn't come even close.

Robert Dyer (psybers) wrote :

@artur: why are you changing bug status for a project you don't belong? Do not touch them.

@Osmo: afaik, this bug is still open.

Changed in do-plugins:
status: Fix Released → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers