Twitter API change breaks Microblogging plugin

Bug #359141 reported by RawIsWar on 2009-04-10
38
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Do Plugins
Medium
Alex Launi
gnome-do-plugins (Ubuntu)
Undecided
Unassigned

Bug Description

It seems that the Twitter API update to change requests from GET to POST (or vice versa - can't remember) has broken the microblogging plugin. It no longer retrieves and shows tweets via notify-osd. No errors are shown.

hobofood (lawrence-anstey) wrote :

from what i can tell from mucking about with the code, the issue is with twitter's API change, and twitterizer supports the new method: http://code.google.com/p/twitterizer/issues/detail?id=18

I would create a patch but I am really really new to linux/c#/mono/bzr and I really have no idea what I am doing past checking out the code and reading it.

Alex Launi (alexlauni) on 2009-04-14
Changed in do-plugins:
assignee: nobody → alexlauni
importance: Undecided → Medium
status: New → In Progress
Alex Launi (alexlauni) on 2009-04-17
Changed in do-plugins:
status: In Progress → Fix Committed
Iain Lane (laney) wrote :
Scott Kitterman (kitterman) wrote :

If you can test that this works, then mark it so in the back and ack from motu-release.

Iain Lane (laney) wrote :

Yes, I've tested it. Uploading now, thanks.

Changed in gnome-do-plugins (Ubuntu):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-do-plugins - 0.8.1.3+dfsg-0ubuntu3

---------------
gnome-do-plugins (0.8.1.3+dfsg-0ubuntu3) jaunty; urgency=low

  * debian/patches/15_twitter_api.dpatch: Backport upstream patch to fix
    compatibility with new Twitter API - changed to require GET or POST
    specifically for some actions instead of accepting either. (LP: #359141)

 -- Iain Lane <email address hidden> Sun, 19 Apr 2009 00:54:44 +0100

Changed in gnome-do-plugins (Ubuntu):
status: Fix Committed → Fix Released
Eric Schwartz (emschwar) wrote :

I just upgraded to the latest gnome-do-plugins, and I still get "Failed to post 'testing update from gnome-do' to Twitter" whenever I try to send it. I'm not sure where to look for any log files to verify whether or not this is the same problem, but it seems suspiciously related.

This is actually not related in the least. Please open a new bug report. The
api change did not affect posting.

--
--Alex Launi

UCAP (ucap) wrote :

I'm on jaunty with the latest gnome-do-plugins (0.8.1.3+dfsg-0ubuntu3) installed, but I still don't get any of my friends' tweets via the new notification system. Posting on the other hand works flawlessly.

tags: added: microblogging official-plugins twitter

+1

I'm on jaunty with the latest version of gnome-do-plugins, and still have this problem.

owboyd@vader:~$ apt-show-versions gnome-do-plugins
gnome-do-plugins/jaunty uptodate 0.8.1.3+dfsg-0ubuntu3

Alan LaMielle (alan.lamielle) wrote :

+1 as well

I've been waiting to see if something would get updated. I've tried clearing out related settings in gconf-editor, uninstalling and reinstalling gnome-do, and restarting gnome. None of these actions seem to make a difference.

Note that I can post successfully, I just do not receive friend updates or direct messages (I've checked both extensively).

Marcos Hack (marcoshack) wrote :

Hi, as well as Alan LaMielle and others I'm using gnome-do-plugins version 0.8.1.3+dfsg-0ubuntu3 and the Microblogging (twiter) friend updates in Jaunty still not working.

I would like to help to test it, Is there a "development" repository or something like that from where we can install a new version?

Thank you.

UCAP (ucap) wrote :

I had the same problem (see above) but clearing out the plugins ( rm -rf ~/.local/share/gnome-do/plugins-* )
and then restarting gnome-do did the trick for me.

Alan LaMielle (alan.lamielle) wrote :

Great! This should be more publicly known. After trying this I'm getting updates now, however the first one I saw was shown twice. I'll post here once I've seen a few more and know that double notifications are happening consistently.

One thing I did notice was that the first of the notifications had the user's icon, and the second had the gnome-do icon. Maybe this is significant?

Alan LaMielle (alan.lamielle) wrote :

Here is what I'm experiencing right now: I get two update notifications rather than one. If the update was from someone that the microblogging plugin had seen before, both updates have the user's icon in the notification. However, if the microblogging plugin does not have the user's icon, the first update has the gnome-do icon, and the second update has the user's icon.

Is anyone else experiencing this?

Alan LaMielle (alan.lamielle) wrote :

Another update on the double update issue: After a few suspends/resumes, it appears that I'm only receiving one notification now. It would probably be better to understand why two were being shown, but the problem is resolved for me at least.

I keep running into the "Rate Limit Exceeded" problem, seemingly because I *view* Twitter with a desktop client but *post* via Gnome-Do.

Even if I uncheck "Show friend Status Updates and DM's", does the Gnome-Do plug-in *still* poll Twitter? Hence I exceed the Rate Limit?

This often happens if you have two Twitter clients open at the same time, but I really don't expect Gnome-Do to check for updates: Just Post.

Alex Launi (alexlauni) on 2009-07-09
Changed in do-plugins:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments