GNOME-Session and upcoming PowerManager breaks Reboot/Shutdown

Bug #339202 reported by Martin on 2009-03-07
2
Affects Status Importance Assigned to Milestone
Do Plugins
Low
Alex Launi

Bug Description

The gnome-pm in the upcoming gnome release no longer supports shutdown() and reboot(). This is now managed by consolekit. I added a bzr diff that uses the ConsoleKit System service to shutdown and reboot.
Not sure how consolekit can be accessed differently (pam/per user daemon) haven't digged into that a lot.

Cheers
Martin

Related branches

Martin (schanzen) wrote :
Martin (schanzen) wrote :
Chris S. (cszikszoy) wrote :

Thanks for the patch Martin. I'll take a look and try to get this in by 0.8.2.

Changed in do-plugins:
assignee: nobody → Chris S. (cszikszoy)
importance: Undecided → Low
milestone: none → 0.8.2
status: New → Confirmed
Alex Launi (alexlauni) on 2009-05-17
Changed in do-plugins:
assignee: Chris S. (cszikszoy) → Alex Launi (alexlauni)
Alex Launi (alexlauni) wrote :

Ok, running this basically just locks up my machine and doesn't reboot on Jaunty. Did you test this?

Martin (schanzen) wrote :

I use it every day since I posted this.

Versions:
ck: 0.3.0
g-p-m: 2.26.1
kernel: 2.6.29
do: 0.8.1.3 + the above patches

I do not use ubuntu though and from what I've seen there are various ways to use ck ( system daemon, user daemon, pam etc). But any of them seem unlikely to cause lockups.
When I get the time I can test it on Fedora (VM) and see what happens...

Martin (schanzen) wrote :

Okay I just tested this in my VM (most recent Fedora 11 RC). Works just fine. Not a lot of code in the patch so the cause seems to be either ubuntu or ck related.

- Martin

Chris S. (cszikszoy) wrote :

I've had time to test this on both Intrepid and Jaunty, and it works flawlessly on both.

Alex Launi (alexlauni) on 2009-05-18
Changed in do-plugins:
status: Confirmed → Fix Committed
Alex Launi (alexlauni) on 2009-07-09
Changed in do-plugins:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers