putty cannot find host when running from gnome do

Bug #324282 reported by Raven on 2009-02-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Do Plugins
Wishlist
Karol Będkowski

Bug Description

gnome do 0.8.0
ubuntu 8.10

gnome do correctly finds my stored sessions but none of them starts. All of them gives the error
"unable to open connection to [session name]:
Name or service not known"

launching it with "putty -load [session name]" works fine

Alex Launi (alexlauni) wrote :

Marking wishlist due to it being a community plugin

Changed in do-plugins:
assignee: nobody → karol-bedkowski
importance: Undecided → Wishlist

Looks like old version of Putty - in my version (build Nov 18 2008) works without -load parameter.
Anyway - patch attached.

patch in trunk

Changed in do-plugins:
status: New → Fix Committed
Chris S. (cszikszoy) on 2009-03-14
Changed in do-plugins:
status: Fix Committed → Fix Released
Raven (andreas-andersson-gmail) wrote :

Thanks!

This just reached me though my update manager and now it works perfect. I had to re-enable all plugins but thats nothing compared to having putty sessions work.

Great job!

Steve Romanow (slestak989) wrote :

This bug is included in the changelog for jaunty-updates, and I have that deb (0.8.1.3+dfsg-0ubuntu3.1) installed. This is still not functional for me. Putty works, but cannot launch by session name.

Steve Romanow (slestak989) wrote :

More info, troubleshooting.

1) Delete .local/gnome-do
2) reinstalled latest gnome-do-plugins deb
3) all of my docky settings reset (expected since I cleared .local/gnome-do)
4) deleted icons in docky and my Putty session entry came up as an icon. (named Prelude)
5) if I click on it it does not work.
6) If I look at the context menu, the only entry is "Connect with Putty", select it and it works.

I guess new version of Putty don't likes spaces in session names.
Are you using spaces in session names?

Changed in do-plugins:
status: Fix Released → Fix Committed
Changed in do-plugins:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers