Max 3000 items in Files and Folders plugin

Bug #324105 reported by mjs7231 on 2009-02-01
24
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Do Plugins
Wishlist
Chris S.

Bug Description

There is a limit of 3000 items allowed to be indexed in the File and Folders plugin. I believe with slightly improved options when adding sources could allow for someone to target more what they want indexed and stay below this line. For example: Currently offered is how deep you want to recurse. It may also be a good idea to allow for such things as:
* Option to allow the user to select how many items to index max and prompt a warning for people pushing this number excessively high.

***** These should go in separate feature requests:
* Limiting the search to file wildcards (ex: *.py, *.java, ...).
* Limiting the search to only files or only directories.

-Chris S.

Jason Smith (jassmith) on 2009-02-01
Changed in do:
status: New → Invalid
importance: Undecided → Wishlist
status: Invalid → Confirmed
Chris S. (cszikszoy) on 2009-02-01
Changed in do-plugins:
assignee: nobody → cszikszoy
status: Confirmed → In Progress
Chris S. (cszikszoy) wrote :

Finally closing this bug. I've allowed the user to change the number of items indexed by F&F plugin. As for the other 2 items on the list, these should go in separate bug reports / feature requests. See my notes in the bug description.

description: updated
Changed in do-plugins:
status: In Progress → Fix Committed

Awesome, look forward to this.

Thanks,
Mike

On Fri, Feb 13, 2009 at 4:38 PM, Chris S. <email address hidden> wrote:

> Finally closing this bug. I've allowed the user to change the number of
> items indexed by F&F plugin. As for the other 2 items on the list,
> these should go in separate bug reports / feature requests. See my
> notes in the bug description.
>
> ** Description changed:
>
> There is a limit of 3000 items allowed to be indexed in the File and
> Folders plugin. I believe with slightly improved options when adding
> sources could allow for someone to target more what they want indexed and
> stay below this line. For example: Currently offered is how deep you want
> to recurse. It may also be a good idea to allow for such things as:
> + * Option to allow the user to select how many items to index max and
> prompt a warning for people pushing this number excessively high.
> +
> + ***** These should go in separate feature requests:
> * Limiting the search to file wildcards (ex: *.py, *.java, ...).
> * Limiting the search to only files or only directories.
> - * Option to allow the user to select how many items to index max and
> prompt a warning for people pushing this number excessively high.
> +
> + -Chris S.
>
> ** Changed in: do-plugins
> Status: In Progress => Fix Committed
>
> --
> Max 3000 items in Files and Folders plugin
> https://bugs.launchpad.net/bugs/324105
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Chris S. (cszikszoy) on 2009-03-14
Changed in do-plugins:
status: Fix Committed → Fix Released
David_jcd (jc-denton-2052) wrote :

I installed gnome-do 0.8.2, but I still can't index more than 3000 files. What should I do?
Thanks,

David

Chris S. (cszikszoy) wrote :

Indexing more than 3000 files isn't recommended. But if you must,
check gconf, /apps/gnome-do/preferences/Do/FilesAndFolders/FilesAndFoldersPreferences
 There should be a key called "MaximumFilesIndexed". Change that to
whatever you want.

On Sat, Sep 26, 2009 at 4:01 AM, David_jcd <email address hidden> wrote:
> I installed gnome-do 0.8.2, but  I still can't index more than 3000 files. What should I do?
> Thanks,
>
> David
>
> --
> Max 3000 items in Files and Folders plugin
> https://bugs.launchpad.net/bugs/324105
> You received this bug notification because you are a bug assignee.
>
> Status in GNOME Do Plugins Project: Fix Released
>
> Bug description:
> There is a limit of 3000 items allowed to be indexed in the File and Folders plugin.  I believe with slightly improved options when adding sources could allow for someone to target more what they want indexed and stay below this line.  For example: Currently offered is how deep you want to recurse.  It may also be a good idea to allow for such things as:
> * Option to allow the user to select how many items to index max and prompt a warning for people pushing this number excessively high.
>
> ***** These should go in separate feature requests:
> * Limiting the search to file wildcards (ex: *.py, *.java, ...).
> * Limiting the search to only files or only directories.
>
> -Chris S.
>

David_jcd (jc-denton-2052) wrote :

Thank you!

McSqueeb (fulksae) wrote :

That folder (/apps/gnome-do/preferences/Do/FilesAndFolders/FilesAndFoldersPreferences) doesn't exist... where do I change the properties?

Robert Dyer (psybers) wrote :

That is a GConf path, not a folder. Please google up changing GConf keys if you need more info.

colinjones (colin-a-jones) wrote :

Nope - that key does not exist even now. The only ones there are:

IncludeHiddenFiles
IncludeHiddenFilesWhenBrowsing
LimitMaximumFilesIndexed

I have tried adding that key as an Integer but it still limits to 3000. And turning off the limit completely with the last key isn't exactly the best solution!

MShepanski (mjs7231) wrote :

My C# and Launchpad knowledge are limited, but I created a branch of gnome-do-plugins that includes an option to limit the files indexed in a specified path by a list of extensions. I believe you need to be using the latest dev build of gnome-do (r1362). My branch is located here: https://code.launchpad.net/~mjs7231/do-plugins/file-and-folders-improvements

Here is a screenshot showing what I am talking about:
http://imgur.com/npOid

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers