"Focus" Action Missing from Window Manager After Upgrade

Bug #323441 reported by Teague Sterling on 2009-01-31
18
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Do Plugins
Medium
Jason Smith

Bug Description

After upgrading to 0.8.0 (could have happened sooner) the window manager plugin only allows the actions: "Minimize", "Maximize", and "Close All". Previously there was a "Focus" action available for running programs. This is also mentioned on the plugin's Wiki page. This has been tested with a number of different applications, none of them offer this action.

All other features of the plugin seem to work as described still, such as "Tile Windows" and the "Current Application" object (again, with the exception of the "Focus" action).

Alex Launi (alexlauni) wrote :

Jason removed this because apparently the code was terrible, I don't agree but it will be added back hopefully soon.

Changed in do-plugins:
assignee: nobody → jassmith
importance: Undecided → Medium
status: New → Confirmed

Thanks for the quick answer.

It was quite a cool feature, here's to hoping it comes back soon.

Jason Smith (jassmith) wrote :

yeah it did funny things with docky, lock cause xlib to shit a brick. Since I didn't have time to debug it, I pulled it

5of0 (cincodenada+ubuntu) wrote :

Thanks for the answer. Maybe add a note on the wiki? I was looking for this feature as well, I wanted to be able to go to a window on another workspace with gnome-do, and was confused since it was on the wiki, but not in my Gnome-Do. Thanks for all the awesome work, and I'll wait patiently for this to be worked out. As a dev myself, I know that these things take time.

tags: added: official-plugins window-manager
Alex Launi (alexlauni) on 2009-05-17
Changed in do-plugins:
milestone: none → 0.8.2
status: Confirmed → Fix Committed
Alex Launi (alexlauni) on 2009-07-09
Changed in do-plugins:
status: Fix Committed → Fix Released
Adrian Rollett (acrollet) wrote :

downloaded, tested and working! Thanks guys, this is awesome!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers