add 'Show Desktop' feature to Window Manager plugin

Bug #323079 reported by dumas33 on 2009-01-30
32
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Do Plugins
Wishlist
Jason Smith

Bug Description

This is wish or feature request, not bug. I already typed it in discussion, but it seems to be better place to fill this.

Docky is real on great my netbook. I removed bottom panel, and set docky to autohide. So, I saved about 8 mm of screen size for apps. Icons can be realy big and shine even on 9 inch screen. Thank you!!! Only feature I miss so far - Show desktop icon. Where can I request that? -dumas

Jason Smith (jassmith) wrote :

not needed. All someone has to do is make a Do plugin to do this and away you go. This is not a Docky specific thing by far.

Changed in do:
status: New → Won't Fix
Alex Launi (alexlauni) on 2009-01-30
Changed in do:
importance: Undecided → Wishlist
status: Won't Fix → Confirmed
António Lima (amrlima) wrote :

I followed David Siegel's tip and made a python script that can acts as show deskop applet.

The script ONLY works with compiz for now.

This is my first attempt to solve this problem and I find it usable at least. What you have to do? Just save the script somewhere, make it executable and create a menu entry for it using a icon (for example desktop.png from gnome-icon-theme). Place the entry in docky and voila, a show desktop applet to go!

Well, I know this not integrates with gnome-do plugins but it solves this problem for now. I'll dig more on the subject later.

António Lima (amrlima) wrote :

Glad you liked it!

I'm currently trying to figure out how to make this work with metacity as well, but its a bit harder since metacity does not interact with dbus.

The solution is what Alex said, using linwnck but I'm having some troubles to make the windows get back after showing the desktop.

If I figure this out maybe I'll try and go for the plugin :)

I'll make that blog post :)

You sent the mail directly to me, I'm posting it here bellow.

Seg, 2009-02-02 às 20:59 -0800, David Siegel escreveu:
Cool, you should do a blog post! Post the script and instructions, and a nice screenshot of course.
>
> Actually, it would also be pretty simple to create a Do plugin for this if you're really ambitious, but I like the current solution.

tags: added: official-plugins window-manager
Alex Launi (alexlauni) on 2009-05-17
Changed in do-plugins:
assignee: nobody → Jason Smith (jassmith)
milestone: none → 0.8.2
status: Confirmed → Fix Committed
ormuz (ormuz) wrote :

Hi,

I've been looking into a way to show the desktop from Do in its docky version with Metacity.
Actually, as Metacity doesn't talk with Dbus, we have to use the EWMH commands to do whatever needs to be done on windows.

Quite fortunately, Tomas Styblo provides a utility called wmctrl (http://tripie.sweb.cz/utils/wmctrl/), which allows managing the EWMH inputs from the command line. It includes a switch to show the desktop. ("wmctrl -k on")

From here, it's then straight forward: create a 1-line script with this command, chmod a+x it and create a launcher for it. You then just need to drag the launcher on Docky, restart it, and you're done: Desktop will show when you click.

Alex Launi (alexlauni) on 2009-07-09
Changed in do-plugins:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments