twitter plugin still reports friend updates even when deactivated

Bug #317674 reported by knoopx on 2009-01-15
38
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Do Plugins
Low
Alex Launi

Bug Description

Notification popups still appear once you deactivate the twitter plugin (without restarting gnome-do)

Chris Miller (chrisamiller) wrote :

I'm confirming this bug.

Despite unchecking the preference box that says: 'Show friend status updates', Do continues to pop up notifications whenever my friends update their status. The preference seems to be ignored completely.

Microblogging (Twitter) v1.0
GNOME Do v0.8.0 Release (from PPA)
OS: Ubuntu 8.10

Changed in do-plugins:
status: New → Confirmed
Amr Hassan (amr-hassan) wrote :

Confirmed

Ubuntu 8.10, Microblogging 1.0, Do 0.8

Evan Meagher (evan-meagher) wrote :

I disabled the microblogging plugin altogether and it's still showing friend update popups.

cokelly (okelly-ciaran) wrote :

I don't know if I'm being helpful but it's not quite right to say that this bug is apparent "without restarting Gnome-Do:" The bug is still apparent (at least in my experience) after restarting gnome-do and after rebooting entirely.

Like Chris and Amr, I'm on Microblogging (Twitter) v1.0; Gnome Do v0.8.0 Release and Ubuntu 8.10.

Fabian A. Scherschel (fabsh) wrote :

Yup, same here. Although deactivating the plugin and restarting gnome-do at least stops the popups from appearing or me.

Aashay Desai (aashayd) wrote :

I did a (VERY) cursory glance at the sourcecode...aside from basic getter/setter methods, it kinda looks like someone forgot to implement the logic to actually check for the parameter...

On Mon, Feb 23, 2009 at 6:56 PM, Aashay Desai <email address hidden> wrote:

> I did a (VERY) cursory glance at the sourcecode...aside from basic
> getter/setter methods, it kinda looks like someone forgot to implement
> the logic to actually check for the parameter..
>

Yes, this is exactly what happened. Microblogging underwent a rewrite, and
this got forgotten. I'll add it back before the next release.

--
--Alex Launi

Alex Launi (alexlauni) on 2009-02-27
Changed in do-plugins:
assignee: nobody → alexlauni
importance: Undecided → Low
status: Confirmed → In Progress
Alex Launi (alexlauni) on 2009-02-27
Changed in do-plugins:
status: In Progress → Fix Committed
Chris S. (cszikszoy) on 2009-03-14
Changed in do-plugins:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers