Pidgin 2.5.4 has incompatible dbus interface. s/uint/int

Bug #314927 reported by ukasz on 2009-01-08
66
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Do Plugins
Low
Chris S.
gnome-do-plugins (Ubuntu)
Medium
Jonathan Davies

Bug Description

using gnome-do to open a chat gives:

5026
Could not create new Pidgin conversation: org.freedesktop.DBus.Error.InvalidArgs: Argument 0 is specified to be of type "int32", but is actually of type "uint32"

ukasz (ukaszg) wrote :

Pidgin 2.5.3
GNOME Do 0.6.1.0

Chris Halse Rogers (raof) wrote :

Gardening; moving to the appropriate do-plugins project.

Stéphane Maniaci (stephh) wrote :

Can confirm this in Jaunty with latest PPA gnome-do package.

Changed in do-plugins:
assignee: nobody → djsiegel
status: New → Fix Committed
Alendit (alendit) wrote :

Jaunty and packages von PPA here (0.7.95.1). Get this message when trying to open a new conversation:

12019
Could not create new Pidgin conversation: org.freedesktop.DBus.Error.InvalidArgs: Argument 0 is specified to be of type "int32", but is actually of type "uint32"

Alendit, please stop reporting on the bug, it is marked fix committed.

Chereji Mihai (croncobaurul) wrote :

I was affected by it with pidgin 2.5.3 and do 0.6.1.0, but once i upgraded to pidgin 2.5.4, it started working again.

Marco (0m3g4) wrote :

Pidgin 2.5.5
GNOME Do 0.7.95.1

same error

I know this bug is marked 'Fix Committed' (on 1-15) but the issue (same error) still persists with
Gnome Do 0.7.99,
Gnome Do Plugins 0.7.98.1,
the latter released on 1-19. Does that mean the fix made it into the release?

I'm still finding my way around Launchpad; is there a way to find out, up to which revisions/commits correspond to which releases?

Thanks

Marco (0m3g4) wrote :

maybe this bug is fixed here: http://bazaar.launchpad.net/~do-plugins/do-plugins/future/changes
(branch future)

Marco (0m3g4) wrote :

one question, i compile gnome-do from bzr trunk,i don't have Gnome Do 0.7.99 but Gnome Do 0.7.98. why?

Ubuntu 8.10 Intrepid
gnome-do 0.8.0
gnome-do-plugins 0.8.0

Issue persists.

Chereji Mihai (croncobaurul) wrote :

When i upgraded to pidgin 2.5.4, I had to uninstall pidgin-dev and the pidgin-plug-in-pack; After that, the plug-in magically worked again. Maybe there's some sort of correlation between the 2 events? Everyone affected by this bug, check if you have those pidgin-dev and the pidgin-plugin-pack installed and uninstall them to check if it makes any difference

Marco (0m3g4) wrote :

i'm using pidgin 2.5.5 unstable compiled from mnt and i have same error...so this bug doesn't depend on these packages

Changed in do-plugins:
status: Fix Committed → Fix Released
Marco (0m3g4) wrote :

fix released where?

leeight (leeight) wrote :

I run into the same problem.

pidgin 2.5.4
gnome-do 0.8

archlinux

leeight (leeight) wrote :

OK

i fix this problem.

change
            int PurpleConversationNew (uint type, int account, string name);
to
            int PurpleConversationNew (int type, int account, string name);

in Pidgin/src/Pidgin.cs

Chris S. (cszikszoy) on 2009-02-10
Changed in do-plugins:
assignee: djsiegel → cszikszoy
status: Fix Released → In Progress
importance: Undecided → Low

Started working fine for me with Do-0.8.0 and specifically Do-plugins 0.8.0.2. Seems to have been fixed with Do-plugins 0.8.0.2.

Alex (alex-lp) wrote :

Not sure if this has made it into the 0.8.0.2 release, but I'm still experiencing the problem. On top of that (should I make a separate bug for this?), I also can't changed my status using the plugin (and don't get any errors reported as far as I can see) other than to a saved status.

Craig Kelley (ink) wrote :

Still having issues for me with gnome-do-plugins-0.8.0 and pidgin-2.5.4.

Where do I get the 0.8.0.2 plugin release?

Chris S. (cszikszoy) wrote :

D-Feet shows the PidginConversationNew method signature having uint as the input, not int. I've made this change in rev 556 of lp:do-plugins/trunk.

UGN (eugene-korneev) wrote :

confirm to,
pidgin 2.5.4 (jaunty)
gnome-do 0.8 / plugins 0.8.0.2 (jaunty)

Chris S. (cszikszoy) wrote :

Alright, the problem is that pidgin 2.5.2 has different dbus method signatures than 2.5.4 does. I'll have to support both sets of dbus methods for now to get this to work properly. I have pidin 2.5.2 so I can check those method signatures, but can anyone with pidgin 2.5.4 check the method signatures (the ones listed here: http://bazaar.launchpad.net/~do-plugins/do-plugins/trunk/annotate/head%3A/Pidgin/src//Pidgin.cs) and give me the variable types?

Craig Kelley (ink) wrote :

Exploring DBUS reveals no uint values for Pidgin 2.5.4; they are all plain int values now.

Chris S. (cszikszoy) wrote :

Thanks, I'll make those changes later tonight. This really wouldn't be a problem if pidgin supported the Introspect () method, like _EVERY OTHER DBUS APP_. But, since pidgin doesn't have that Introspect () method there's no way for me to check the method signatures at runtime.

Alex Launi (alexlauni) on 2009-03-01
Changed in do-plugins:
status: In Progress → Fix Committed
Jonathan Davies (jpds) on 2009-03-07
Changed in gnome-do-plugins:
assignee: nobody → jpds
importance: Undecided → Medium
milestone: none → jaunty-alpha-6
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-do-plugins - 0.8.0.2+dfsg1-1~ubuntu2

---------------
gnome-do-plugins (0.8.0.2+dfsg1-1~ubuntu2) jaunty; urgency=low

  * Added debian/patches/04_fix_pidgin_dbus_ints.patch: Fixes D-Bus errors with
    Pidgin Chat plugin - backported fix from upstream (Bazaar revision 557)
    (LP: #314927).

 -- Jonathan Davies <email address hidden> Sat, 07 Mar 2009 21:46:57 +0000

Changed in gnome-do-plugins:
status: In Progress → Fix Released
Chris S. (cszikszoy) on 2009-03-14
Changed in do-plugins:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers