Banshee plugin goes crazy if banshee isn't loaded first

Bug #289802 reported by Chris Halse Rogers on 2008-10-27
2
Affects Status Importance Assigned to Milestone
Do Plugins
Medium
Alex Launi

Bug Description

I've pulled the latest Banshee-1 code - revno 273 from lp:~alexlauni/do-plugins/bansheeplugin/

The plugin goes crazy if started before Banshee is - the log suggests that it's trying to get org.bansheeproject.Indexer over and over and over again. Furthermore, starting up Banshee after this causes banshee to spawn many indexers and consume all memory & CPU.

The process to reproduce the log is:
Start Do.
Wait for the exception storm to end, and for Universe to have been populated.
Start Banshee-1; this spawned upwards of 20 indexing backends.
Kill Banshee-1, which is unresponsive. This triggers the mega backtrace http://paste2.org/p/92845 from Do.

Chris Halse Rogers (raof) wrote :
Changed in do-plugins:
assignee: nobody → alexlauni
Alex Launi (alexlauni) wrote :

How have you installed banshee? That service should be provided. Is Banshee trunk installed system wide or in a user only place. I know you're smart enough to not always install trunk code system wide and I think that might be the problem. Could you verify your Banshee install for me please?

Changed in do-plugins:
importance: Undecided → Medium

No matter how he has Banshee installed, the plugin should not cause this
havoc.

David

On Mon, Oct 27, 2008 at 6:39 AM, Alex Launi <email address hidden> wrote:

> How have you installed banshee? That service should be provided. Is
> Banshee trunk installed system wide or in a user only place. I know
> you're smart enough to not always install trunk code system wide and I
> think that might be the problem. Could you verify your Banshee install
> for me please?
>
> ** Changed in: do-plugins
> Importance: Undecided => Medium
>
> --
> Banshee plugin goes crazy if banshee isn't loaded first
> https://bugs.launchpad.net/bugs/289802
> You received this bug notification because you are a member of GNOME Do
> Plugins Team, which is subscribed to GNOME Do Plugins.
>
> _______________________________________________
> Mailing list: https://launchpad.net/~do-plugins<https://launchpad.net/%7Edo-plugins>
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~do-plugins<https://launchpad.net/%7Edo-plugins>
> More help : https://help.launchpad.net/ListHelp
>

Chris Halse Rogers (raof) wrote :

You're absolutely correct; I don't have a system-wide Banshee install.

I'll see if I can duplicate with a system-wide install, but this obviously needs to be fixed regardless.

Chris Halse Rogers (raof) wrote :

Incidentally, isn't that a cool backtrace? :)

Alex Launi (alexlauni) on 2009-01-16
Changed in do-plugins:
status: New → Confirmed
Alex Launi (alexlauni) wrote :

Could you please test the latest revision. This has been fixed.

Changed in do-plugins:
status: Confirmed → Fix Committed
Chris S. (cszikszoy) on 2009-03-14
Changed in do-plugins:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments