Fix appindicator icons

Bug #722520 reported by Jason Gerard DeRose on 2011-02-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Dmedia
Critical
David Green

Bug Description

Seems some API in change in `appindicator` in Natty has broken the dmedia icons. I'm using a absolute path rather than icon name, now it doesn't work.

I wasn't really doing this the right way anyway, so good time to fix it.

See dmedia/service.py for details.

Related branches

lp:~david4dev/dmedia/fix-indicator-icons
Jason Gerard DeRose: Approve on 2011-02-23
tags: added: bitesize
David Green (david4dev) on 2011-02-22
Changed in dmedia:
assignee: nobody → David Green (david4dev)
David Green (david4dev) wrote :

http://people.canonical.com/~ted/libappindicator/current/AppIndicator.html

The problem is in app_indicator_new() I think. The creation of an AppIndicator seems to require an icon_name.
http://imgur.com/n1X17

I think following this:

    http://standards.freedesktop.org/icon-theme-spec/icon-theme-spec-latest.html#install_icons

will enable us to use icon names.

Jason Gerard DeRose (jderose) wrote :

David Green is back! :)

David Green (david4dev) on 2011-02-22
Changed in dmedia:
status: Triaged → In Progress
David Green (david4dev) wrote :

I am!

This was the first bug in a long time that wasn't over my head and I think I've fixed it. I'm on 10.10 so I haven't been able to thoroughly test it. I can build a package but I can't install it properly due to missing dependencies. I managed to install it with `dpkg -i --force-depends` but then I can't run dmedia-import because I get errors.

However, I did manage to confirm that the icons can now be used by name. Using a python console I managed to get the images to show by using gtk.image_new_from_icon_name().

David Green (david4dev) on 2011-02-22
Changed in dmedia:
status: In Progress → Fix Committed
Changed in dmedia:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers