Upgrade Silva Glossary to Silva 1.4

Bug #5735 reported by Samuel Schluep on 2005-12-12
4
Affects Status Importance Assigned to Milestone
Silva dLCMS
Medium
Unassigned

Bug Description

Silva Glossary is compatible to Silva 1.1 and should be upgraded to Silva 1.4. It is probably a good idea to make a branch in the SVN for the Silva 1.1 and also 1.2 version if the final 1.4 upgrade will not be compatible to Silva 1.2.

Eric Casteleijn (thisfred) wrote :

This is done, but could use some testing.

Samuel Schluep (schluep) wrote :

Testing it on a Silva 1.2 instance. Does quite well already. There is one problem I have found so far: glossary entries in the index (default) page of a container do not find their way onto the glossary page on a glossary update. _getGlossarizable does not seem to get all objects! (This might also be a problem with the Silva core Indexer code?)

Eric Casteleijn (thisfred) wrote :

Ah, ok, I think I can fix that by adding a container adapter like in the indexer.

Eric Casteleijn (thisfred) wrote :

Added. I will test 1.4, could you try in your 1.2 instance again?

Samuel Schluep (schluep) wrote :

The glossary update now gets the glossary entries of the index documents of the sub-folders, but not the one of its parent folder (in my opinion a glossary inside a dLCMS Lesson should also contain the entries of the lesson's opening or default page).

Samuel Schluep (schluep) on 2006-02-03
Changed in dlcms:
status: Unconfirmed → Confirmed
Samuel Schluep (schluep) on 2006-03-10
Changed in dlcms:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers