OBSOLETE_BY in DKMS.CONF does not work

Bug #1828948 reported by Alex Tu on 2019-05-14
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
DKMS
Undecided
Unassigned
OEM Priority Project
High
Alex Tu
dkms (Ubuntu)
High
Unassigned
Bionic
High
Gianfranco Costamagna
Disco
High
Unassigned

Bug Description

[Impact]
OBSOLETE_BY in DKMS.CONF not work
Which also be reported on upstream:
https://github.com/dell/dkms/issues/81

[Test case]
1. add OBSOLETE_BY in DKMS.CONF
e.g. OBSOLETE_BY="4.15.0-1033"
2. the kernel module should not be built with kernel greater than the version specified by OBSOLETE_BY
e.g.
 - user install kernel 4.15.0-1030 and 4.15.0-10360
 - user install kernel oem-wifi-qualcomm-ath10k-lp1803647-4.15-dkms [1] which has OBSOLETE_BY="4.15.0-1033"
 - the kernel module from dkms [1] should only built for 4.15.0-1030, but not for 4.15.0-10360

[Regression potential]
None as it used to work, but somehow regression there.

[1] https://code.launchpad.net/~alextu/+recipe/oem-wifi-qualcomm-ath10k-lp1803647-4.15-dkms-daily

Alex Tu (alextu) on 2019-05-14
Changed in dkms:
assignee: nobody → Alex Tu (alextu)
importance: Undecided → High
status: New → Confirmed
Alex Tu (alextu) wrote :

I prepared the required patch based on the merged solution from upstream

https://github.com/alex-tu-cc/dkms/commit/53b0e857717fbeda637ed822a9e9c929d2afaf5c

the package built from the proposed patch for Ubuntu dkms package (dkms - 2.3-3ubuntu9.3):
https://launchpad.net/~alextu/+archive/ubuntu/test/+sourcepub/10146781/+listing-archive-extra

the DKMS I used to verify this fix:
https://code.launchpad.net/~alextu/+recipe/oem-wifi-qualcomm-ath10k-lp1803647-4.15-dkms-daily

Alex Tu (alextu) on 2019-05-14
Changed in oem-priority:
assignee: nobody → Alex Tu (alextu)
Changed in dkms:
assignee: Alex Tu (alextu) → nobody
importance: High → Undecided
Changed in oem-priority:
importance: Undecided → High

I'll sponsor this patch.

Please follow the steps at https://wiki.ubuntu.com/StableReleaseUpdates#Procedure to update the bug description for SRUing this to bionic.

Alex Tu (alextu) on 2019-05-15
description: updated
Alex Tu (alextu) wrote :
Alex Tu (alextu) wrote :

@Mathieu,
Thanks for help , the description is modified and patch has been uploaded to #3 as well.

Changed in oem-priority:
status: New → Fix Committed

The attachment "dkms_2.3-3ubuntu9.3.debdiff" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dkms - 2.6.1-4ubuntu3

---------------
dkms (2.6.1-4ubuntu3) eoan; urgency=medium

  [ Alex Tu ]
  * debian/patches/0017-fix-OBSOLETE_BY-in-DKMS.CONF-Closes-81.patch:
    Fix support for OBSOLETE_BY in DKMS.CONF (LP: #1828948)

 -- Mathieu Trudel-Lapierre <email address hidden> Tue, 14 May 2019 16:46:26 -0400

Changed in dkms (Ubuntu):
status: New → Fix Released
Changed in dkms (Ubuntu):
importance: Undecided → High
Changed in dkms (Ubuntu Bionic):
importance: Undecided → High
Mathew Hodson (mathew-hodson) wrote :
Changed in dkms:
status: Confirmed → Fix Released
tags: added: regression-release
Rex Tsai (chihchun) on 2019-06-11
tags: added: oem-priority
Brian Murray (brian-murray) wrote :

It would also be good to get this fixed in Ubuntu 19.04 codename Disco Dingo.

summary: - OBSOLETE_BY in DKMS.CONF not work
+ OBSOLETE_BY in DKMS.CONF does not work
Changed in dkms (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic

Hello Alex, or anyone else affected,

Accepted dkms into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/dkms/2.3-3ubuntu9.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Łukasz Zemczak (sil2100) wrote :

Hello Alex, or anyone else affected,

Accepted dkms into disco-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/dkms/2.6.1-4ubuntu2.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-disco to verification-done-disco. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-disco. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in dkms (Ubuntu Disco):
status: New → Fix Committed
tags: added: verification-needed-disco
Changed in dkms (Ubuntu Disco):
importance: Undecided → High
Alex Tu (alextu) wrote :

I verified the 2.6.1-4ubuntu2.2 dkms in VM by multipass snap with changed dkms [1], it works as expected.

system has linux-image-5.0.0-20-generic and linux-image-5.0.0-21-generic be installed.
With OBSOLETE_BY="5.0.0-21" , then the DKMS will only be installed for kernel 5.0.0-20.
With OBSOLETE_BY="5.0.0-20" , then the DKMS not be installed for both kernel.

[1] https://code.launchpad.net/~alextu/+git/acpi-call-dkms-test-obsolete

tags: added: verification-done-disco
removed: verification-needed-disco
Alex Tu (alextu) wrote :

for #10, also followed the testing environment of #12 and tested passed on bionic as well.

tags: added: verification-done-bionic
removed: verification-needed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dkms - 2.6.1-4ubuntu2.2

---------------
dkms (2.6.1-4ubuntu2.2) disco; urgency=medium

  * 0017-fix-OBSOLETE_BY-in-DKMS.CONF-Closes-81.patch: OBSOLETE_BY in DKMS.CONF
    (LP: #1828948)

 -- Alex Tu <email address hidden> Wed, 03 Jul 2019 14:01:45 -0400

Changed in dkms (Ubuntu Disco):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for dkms has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dkms - 2.3-3ubuntu9.4

---------------
dkms (2.3-3ubuntu9.4) bionic; urgency=medium

  * 0017-fix-OBSOLETE_BY-in-DKMS.CONF-Closes-81.patch: OBSOLETE_BY in DKMS.CONF
    (LP: #1828948)

 -- Alex Tu <email address hidden> Tue, 14 May 2019 16:48:00 +0800

Changed in dkms (Ubuntu Bionic):
status: Fix Committed → Fix Released

This patch relies on a function that has been implemented later. I'm reopening the bug and uploading a fix for this one.

vboxpci.ko:
Running module version sanity check.
/usr/sbin/dkms: line 784: find_module: command not found
modinfo: ERROR: missing module or filename.
 - Original module
   - No original module exists within this kernel
 - Installation

Changed in dkms (Ubuntu Bionic):
status: Fix Released → New
Changed in dkms (Ubuntu Disco):
status: Fix Released → New

Disco is fine, because the fund_module function is implemented already in 2.6.1

Changed in dkms (Ubuntu Disco):
status: New → Fix Committed
status: Fix Committed → Fix Released
Changed in dkms (Ubuntu Bionic):
status: New → In Progress
assignee: nobody → Gianfranco Costamagna (costamagnagianfranco)
tags: added: regression-update

There is a sru request for this regression already, and land another change
from upstream. Sorry for inconvenient.
https://bugs.launchpad.net/ubuntu/+source/dkms/+bug/1838245

Gianfranco Costamagna <email address hidden> 於 2019年8月1日 週四 下午7:20
寫道:

> Disco is fine, because the fund_module function is implemented already
> in 2.6.1
>
> ** Changed in: dkms (Ubuntu Disco)
> Status: New => Fix Committed
>
> ** Changed in: dkms (Ubuntu Disco)
> Status: Fix Committed => Fix Released
>
> ** Changed in: dkms (Ubuntu Bionic)
> Status: New => In Progress
>
> ** Changed in: dkms (Ubuntu Bionic)
> Assignee: (unassigned) => Gianfranco Costamagna (costamagnagianfranco)
>
> ** Tags added: regression-update
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1828948
>
> Title:
> OBSOLETE_BY in DKMS.CONF does not work
>
> Status in DKMS:
> Fix Released
> Status in OEM Priority Project:
> Fix Committed
> Status in dkms package in Ubuntu:
> Fix Released
> Status in dkms source package in Bionic:
> In Progress
> Status in dkms source package in Disco:
> Fix Released
>
> Bug description:
> [Impact]
> OBSOLETE_BY in DKMS.CONF not work
> Which also be reported on upstream:
> https://github.com/dell/dkms/issues/81
>
> [Test case]
> 1. add OBSOLETE_BY in DKMS.CONF
> e.g. OBSOLETE_BY="4.15.0-1033"
> 2. the kernel module should not be built with kernel greater than the
> version specified by OBSOLETE_BY
> e.g.
> - user install kernel 4.15.0-1030 and 4.15.0-10360
> - user install kernel oem-wifi-qualcomm-ath10k-lp1803647-4.15-dkms [1]
> which has OBSOLETE_BY="4.15.0-1033"
> - the kernel module from dkms [1] should only built for 4.15.0-1030,
> but not for 4.15.0-10360
>
> [Regression potential]
> None as it used to work, but somehow regression there.
>
> [1] https://code.launchpad.net/~alextu/+recipe/oem-wifi-qualcomm-
> ath10k-lp1803647-4.15-dkms-daily
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/dkms/+bug/1828948/+subscriptions
>

Steve Langasek (vorlon) on 2019-08-01
tags: removed: regression-release

ok lets followup in the other bug

Changed in dkms (Ubuntu Bionic):
status: In Progress → Fix Released
tags: added: regression-release
removed: regression-update verification-needed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.