4.18 mainline kernel fails to build nvidia dkms driver

Bug #1787262 reported by d33tah
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
DKMS
Undecided
Unassigned
Linux
New
Undecided
Unassigned
Nvidia
Undecided
Unassigned

Bug Description

Package installation log includes the following:

/etc/kernel/header_postinst.d/dkms:
ERROR (dkms apport): kernel package linux-headers-4.18.0-041800-generic is not supported
Error! Bad return status for module build on kernel: 4.18.0-041800-generic (x86_64)

"dkms --all autoinstall" gives me the following:

Error! Your kernel headers for kernel cannot be found.
Please install the linux-headers- package,
or use the --kernelsourcedir option to tell DKMS where it's located

Note the double space in: "kernel cannot". It looks as if it tried to print an empty string - version detection failed? I do have package headers installed:

root@d33tah-pc:/tmp/kernel# dpkg -l | grep 'linux.*4.18'
ii linux-headers-4.18.0-041800 4.18.0-041800.201808122131 all Header files related to Linux kernel version 4.18.0
ii linux-headers-4.18.0-041800-generic 4.18.0-041800.201808122131 amd64 Linux kernel headers for version 4.18.0 on 64 bit x86 SMP
ii linux-image-unsigned-4.18.0-041800-generic 4.18.0-041800.201808122131 amd64 Linux kernel image for version 4.18.0 on 64 bit x86 SMP
ii linux-modules-4.18.0-041800-generic 4.18.0-041800.201808122131 amd64 Linux kernel extra modules for version 4.18.0 on 64 bit x86 SMP

d33tah (d33tah)
no longer affects: acpi-call (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers