project list cache keeps growing

Bug #1451943 reported by Lin Hua Cheng on 2015-05-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Dashboard (Horizon)
Medium
Lin Hua Cheng
django-openstack-auth
Medium
Lin Hua Cheng

Bug Description

The project list is cache on the dict per process, if running on multi-process, project switch or logout does not remove the project list from the cache.

Changed in django-openstack-auth:
status: New → Confirmed
status: Confirmed → New
assignee: nobody → Lin Hua Cheng (lin-hua-cheng)
importance: Undecided → Medium

Fix proposed to branch: master
Review: https://review.openstack.org/235609

Changed in django-openstack-auth:
status: New → In Progress

Fix proposed to branch: master
Review: https://review.openstack.org/244420

Changed in horizon:
assignee: nobody → Lin Hua Cheng (lin-hua-cheng)
status: New → In Progress

Reviewed: https://review.openstack.org/244420
Committed: https://git.openstack.org/cgit/openstack/horizon/commit/?id=6f83d38da2b2eed5ac5c8854c05f6e6b029fc215
Submitter: Jenkins
Branch: master

commit 6f83d38da2b2eed5ac5c8854c05f6e6b029fc215
Author: lin-hua-cheng <email address hidden>
Date: Wed Nov 11 19:40:43 2015 -0800

    Remove usage of user project caching

    The caching is done only per process, so the cleanup during logout
    does not really work since the during could be handled by another
    process. So the cache will just keep on growing.

    Change-Id: I793fbee44eb5f9befc316efe6716971b0e32172b
    Partial-Bug: #1451943

Reviewed: https://review.openstack.org/235609
Committed: https://git.openstack.org/cgit/openstack/django_openstack_auth/commit/?id=91dec7239da7eb7c6dad385b42aa8aa5a7efa422
Submitter: Jenkins
Branch: master

commit 91dec7239da7eb7c6dad385b42aa8aa5a7efa422
Author: lin-hua-cheng <email address hidden>
Date: Thu Oct 15 16:09:05 2015 -0700

    Revert - Cache the User's Project by Token ID

    The caching is done only per process, so the cleanup during logout
    does not really work since the during could be handled by another
    process. So the cache will just keep on growing.

    This reverts commit bd9fd598e6c2ff11f8c31098cd25c7a42a97d761.

    Depends-On: I793fbee44eb5f9befc316efe6716971b0e32172b
    Change-Id: If878d77533ea5fac86fbb73127f26908f1097091
    Closes-Bug: #1451943

Changed in django-openstack-auth:
status: In Progress → Fix Released
Changed in horizon:
importance: Undecided → Medium

This issue was fixed in the openstack/django_openstack_auth 2.1.0 release.

Changed in horizon:
status: In Progress → Fix Released
milestone: none → mitaka-2
Changed in django-openstack-auth:
milestone: none → 2.1.1

Reviewed: https://review.openstack.org/260948
Committed: https://git.openstack.org/cgit/openstack/django_openstack_auth/commit/?id=31ab61d3b5a0ae7bd281e975f955136b9adebdb6
Submitter: Jenkins
Branch: stable/liberty

commit 31ab61d3b5a0ae7bd281e975f955136b9adebdb6
Author: lin-hua-cheng <email address hidden>
Date: Thu Oct 15 16:09:05 2015 -0700

    Revert - Cache the User's Project by Token ID

    The caching is done only per process, so the cleanup during logout
    does not really work since the during could be handled by another
    process. So the cache will just keep on growing.

    This reverts commit bd9fd598e6c2ff11f8c31098cd25c7a42a97d761.

    Change-Id: If878d77533ea5fac86fbb73127f26908f1097091
    Closes-Bug: #1451943
    (cherry picked from commit 91dec7239da7eb7c6dad385b42aa8aa5a7efa422)

tags: added: in-stable-liberty

Reviewed: https://review.openstack.org/260947
Committed: https://git.openstack.org/cgit/openstack/horizon/commit/?id=e3db0a8956d7a602aea8097f15c1bf05a185622b
Submitter: Jenkins
Branch: stable/liberty

commit e3db0a8956d7a602aea8097f15c1bf05a185622b
Author: lin-hua-cheng <email address hidden>
Date: Wed Nov 11 19:40:43 2015 -0800

    Remove usage of user project caching

    The caching is done only per process, so the cleanup during logout
    does not really work since the during could be handled by another
    process. So the cache will just keep on growing.

    Change-Id: I793fbee44eb5f9befc316efe6716971b0e32172b
    Partial-Bug: #1451943
    (cherry picked from commit 6f83d38da2b2eed5ac5c8854c05f6e6b029fc215)

Reviewed: https://review.openstack.org/260949
Committed: https://git.openstack.org/cgit/openstack/django_openstack_auth/commit/?id=bf88c1789619fb90cca880c60c48e3fe10811555
Submitter: Jenkins
Branch: stable/kilo

commit bf88c1789619fb90cca880c60c48e3fe10811555
Author: lin-hua-cheng <email address hidden>
Date: Thu Oct 15 16:09:05 2015 -0700

    Revert - Cache the User's Project by Token ID

    The caching is done only per process, so the cleanup during logout
    does not really work since the during could be handled by another
    process. So the cache will just keep on growing.

    This reverts commit bd9fd598e6c2ff11f8c31098cd25c7a42a97d761.

    Change-Id: If878d77533ea5fac86fbb73127f26908f1097091
    Closes-Bug: #1451943
    (cherry picked from commit 91dec7239da7eb7c6dad385b42aa8aa5a7efa422)

tags: added: in-stable-kilo

This issue was fixed in the openstack/django_openstack_auth 1.2.2 release.

Change abandoned by Itxaka Serrano Garcia (<email address hidden>) on branch: stable/kilo
Review: https://review.openstack.org/260951
Reason: kilo is security only :(

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers