deprecate doa-kerberos by using setuptools optional dependencies

Bug #1584432 reported by Steve Martinelli
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
django-openstack-auth
Undecided
Steve Martinelli
django-openstack-auth-kerberos
Undecided
Steve Martinelli

Bug Description

The django-openstack-auth-kerberos project[1] should be deprecated and it's functionality should be collapsed into django-openstack-auth proper, by way of setuptool's optional dependencies.

Simply have a section in setup.cfg called 'kerberos' that installs the kerberos package, if a deployer wanted to install django-openstack-auth with kerberos, they would type something like... pip install django-openstack-auth[kerberos].

[1] https://github.com/openstack/django-openstack-auth-kerberos

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to django-openstack-auth-kerberos (master)

Fix proposed to branch: master
Review: https://review.openstack.org/398567

Changed in django-openstack-auth:
assignee: nobody → Steve Martinelli (stevemar)
status: New → In Progress
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to django_openstack_auth (master)

Fix proposed to branch: master
Review: https://review.openstack.org/398573

Changed in django-openstack-auth-kerberos:
status: New → In Progress
assignee: nobody → Steve Martinelli (stevemar)
Revision history for this message
Steve Martinelli (stevemar) wrote :

ayound from red hat confirmed that they will no longer use the doa-kerb package, and instead use federation. the entire package can be removed.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Change abandoned on django_openstack_auth (master)

Change abandoned by Steve Martinelli (<email address hidden>) on branch: master
Review: https://review.openstack.org/398573

Changed in django-openstack-auth:
status: In Progress → Invalid
Changed in django-openstack-auth:
status: Invalid → In Progress
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to django-openstack-auth-kerberos (master)

Reviewed: https://review.openstack.org/398567
Committed: https://git.openstack.org/cgit/openstack/django-openstack-auth-kerberos/commit/?id=517d3ff3bb57fabd94838984a2a4ab1e28d64187
Submitter: Jenkins
Branch: master

commit 517d3ff3bb57fabd94838984a2a4ab1e28d64187
Author: Steve Martinelli <email address hidden>
Date: Wed Nov 16 15:16:43 2016 -0500

    deprecate the entire library

    the library is essentially unmaintained, no tests have been added
    since it's inception 1.5 years ago.

    we can move the functionality to django_openstack_auth proper
    using extras, or attic the entire library if no one is using it.
    either way, this is a step toward both of those outcomes.

    Change-Id: I5e2cf2852e89586415ddbe8da022f7461b3ba0d6
    Closes-Bug: 1584432

Changed in django-openstack-auth:
status: In Progress → Fix Released
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Related fix proposed to django-openstack-auth-kerberos (master)

Related fix proposed to branch: master
Review: https://review.openstack.org/399637

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/django-openstack-auth-kerberos 0.3.0

This issue was fixed in the openstack/django-openstack-auth-kerberos 0.3.0 release.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Related fix merged to django-openstack-auth-kerberos (master)

Reviewed: https://review.openstack.org/399637
Committed: https://git.openstack.org/cgit/openstack/django-openstack-auth-kerberos/commit/?id=22f2889fd925f40aa10c56f18d9590cadb5de637
Submitter: Jenkins
Branch: master

commit 22f2889fd925f40aa10c56f18d9590cadb5de637
Author: Steve Martinelli <email address hidden>
Date: Fri Nov 18 10:28:59 2016 -0500

    delete all files in the repo

    the project was barely maintained and will be retired. deleting all the
    file in the repo (with the exception of the README) is the next step to
    retiring the project completely.

    For the full guide on retiring a repo:
      http://docs.openstack.org/infra/manual/drivers.html#retiring-a-project

    Related-Bug: 1584432

    Depends-On: I25c5d6f50b72d924ec95f88b9c31145e6e38b071
    Change-Id: I4d1922702b64d30a702d1e4a3c63952029581978

Changed in django-openstack-auth-kerberos:
status: In Progress → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers