Removal of request.REQUEST in Django 1.9 breaks django-openid-auth

Bug #1520655 reported by Andrew Starr-Bochicchio on 2015-11-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
django-openid-auth
Undecided
Unassigned
django-openid-auth (Debian)
Fix Released
Unknown

Bug Description

Running the test suite against Django 1.9 produces quite a few failure like this:

======================================================================
ERROR: test_login (django_openid_auth.tests.test_views.RelyingPartyTests)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/lamby/temp/cdt.20151126160041.EQwpnGdGq9/django-openid-auth-0.5/django_openid_auth/tests/test_views.py", line 246, in test_login
    response = self.client.get('/openid/login/')
  File "/usr/lib/python2.7/dist-packages/django/test/client.py", line 503, in get
    **extra)
  File "/usr/lib/python2.7/dist-packages/django/test/client.py", line 304, in get
    return self.generic('GET', path, secure=secure, **r)
  File "/usr/lib/python2.7/dist-packages/django/test/client.py", line 380, in generic
    return self.request(**r)
  File "/usr/lib/python2.7/dist-packages/django/test/client.py", line 467, in request
    six.reraise(*exc_info)
  File "/usr/lib/python2.7/dist-packages/django/core/handlers/base.py", line 149, in get_response
    response = self.process_exception_by_middleware(e, request)
  File "/usr/lib/python2.7/dist-packages/django/core/handlers/base.py", line 147, in get_response
    response = wrapped_callback(request, *callback_args, **callback_kwargs)
  File "/home/lamby/temp/cdt.20151126160041.EQwpnGdGq9/django-openid-auth-0.5/django_openid_auth/views.py", line 152, in login_begin
    redirect_to = request.REQUEST.get(redirect_field_name, '')
AttributeError: 'WSGIRequest' object has no attribute 'REQUEST'

See: https://docs.djangoproject.com/en/1.9/releases/1.9/#features-removed-in-1-9
Full test output here: https://bugs.debian.org/cgi-bin/bugreport.cgi?msg=5;bug=806352;filename=django-openid-auth_0.5-2.2_amd64.build.txt.gz;att=1

Changed in django-openid-auth (Debian):
status: Unknown → Confirmed
Changed in django-openid-auth (Debian):
status: Confirmed → Fix Released
Daniel Holbach (dholbach) wrote :

Because of this bug the package was removed from Debian.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.