execute_manager removed in Django 1.6

Bug #1252445 reported by Andrew Starr-Bochicchio on 2013-11-18
This bug affects 1 person
Affects Status Importance Assigned to Milestone
django-openid-auth (Debian)
Fix Released
django-openid-auth (Ubuntu)

Bug Description

execute_manager was put on the deprecation path as part of the project layout refactor in Django 1.4 https://docs.djangoproject.com/en/1.4/releases/1.4/#django-core-management-execute-manager. Per the deprecation policy that means that the code for execute_manager has been completely removed in 1.6. django-openid-auth still uses it in the example_consumer.

django-openid-auth fails to build with django 1.6 in Debian:
| debian/rules override_dh_auto_test
| make[1]: Entering directory `/«PKGBUILDDIR»'
| set -e; \
| for python in python2.7; do \
| PYTHONPATH="." $python example_consumer/manage.py test --settings=example_consumer.settings django_openid_auth ; \
| done
| Traceback (most recent call last):
| File "example_consumer/manage.py", line 2, in <module>
| from django.core.management import execute_manager
| ImportError: cannot import name execute_manager
| make[1]: *** [override_dh_auto_test] Error 1

Related branches

description: updated
Changed in django-openid-auth (Debian):
status: Unknown → Confirmed
Luke Faraone (lfaraone) on 2013-11-19
Changed in django-openid-auth (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Changed in django-openid-auth:
status: New → Confirmed
Andreas Moog (ampelbein) wrote :
tags: added: ftbfs trusty
Changed in django-openid-auth (Ubuntu):
importance: Low → High

Note that LP: #1252826 is really the bigger problem. Even if you fix the test failure using my branch, most existing projects using django-openid-auth are still going to be broken with Django 1.6 I was hoping that upstream would have some movement with the issue, especially since 14.04 will be a LTS and Canonical has deployments using it. Unfortunately, that doesn't seem to be happening.

I'm debating just making a upload to Debian with a NEWS entry informing users that they'll have to set SESSION_SERIALIZER to pickle. Though there is a very good reason for the change. It might just be better to find a new openid solution and ask for this to be removed from Trusty...

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package django-openid-auth - 0.5-2

django-openid-auth (0.5-2) unstable; urgency=medium

  * debian/patches/django1.6compat.patch: Fix compatibility
    issues with Django 1.6 (Closes: #729828, 739617)
    (LP: #1252866, #1252445).
  * Add debian/NEW entry describing the situation with
    the new Django session serializer.
  * Bump Standards-Version to 3.9.5, no changes needed.
  * Transition from python-support to dh_python2.

 -- Andrew Starr-Bochicchio <email address hidden> Sat, 22 Feb 2014 13:00:49 -0500

Changed in django-openid-auth (Ubuntu):
status: Triaged → Fix Released
Changed in django-openid-auth (Debian):
status: Confirmed → Fix Released
Changed in django-openid-auth:
status: Confirmed → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.