Disper unable to find screens (only default)

Bug #972895 reported by Stephane Mouton on 2012-04-03
This bug affects 1 person
Affects Status Importance Assigned to Milestone

Bug Description

When I type disper -l with two screens connected, all I get is "display default: default" (and resultions) instead of a list of connected screens with associate resolutions.
Here are some clues:
- Attempted to use disper 0.3.0
- I'm on OpenSUSE12.1 with Gnome 3
- worked on Fedora 16 with Gnome 3 (same hardware)
- in both case I used NVidia proprietary drivers and nvidia-settings works fine
- I dug into bugs and tested code found in #581623
  cd /usr/share/disper/src
  python -c 'from switcher.swnvidia import *; NVidiaSwitcher()'
  python -c 'from nvidia import *; NVidiaControl()'
1) Code returns nothing on Fedora 16 (where disper works fine)
2) Code returns same error on OpenSUSE 12.1:
% python -c 'from switcher.swnvidia import *; NVidiaSwitcher()'
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "switcher/swnvidia.py", line 32, in __init__
    self.nv = nvidia.NVidiaControl()
  File "nvidia/nvctrl.py", line 570, in __init__
  File "nvidia/nvctrl.py", line 578, in init_NV_CONTROL
    self.xsock, self.xconn = minx.XConnect()
  File "nvidia/minx.py", line 403, in XConnect
    auth_name, auth_data = xnet.get_X_auth( xsock, name, host, displayno )
TypeError: 'NoneType' object is not iterable
Any idea?

As requested, I attached Xorg.0.log
Best Regards

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments