Wrong cli parameters give cryptic error messages

Bug #701395 reported by freak42 on 2011-01-11
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
disper
Wishlist
wvengen

Bug Description

Not so much a bug as a nuisance.

Calling disper with a wrong formatted set of cli parameters returns strange error messages:

> disper -d auto -e -direction=left
the above command should feature two dashes before direction "--direction": the command is parsed as -d (display) and uses "irection" as a display name and therefore raises the error "Garbage metamode: restart X before changing the display configuration to avoid crashes in the nVidia driver" in my case.

Obviously this is my fault, however it took me a great deal to find out the cause of the problem and providing a more appropriate error message might be sensible.

Jamie Krug (jamie-thekrugs) wrote :

FWIW, I ran into this when attempting...
disper -e -d=DFP-1,DFP-0
...instead, I needed a space after the -d option, not an equals sign:
disper -e -d DFP-1,DFP-0

On the bright side, disper now saves me about 17 clicks per day :D No more NVIDIA X Server Settings GUI!

wvengen (wvengen) wrote :

Thanks for your bug report! While you're right that the error messages are not as clear as they could be, this is due to the underlying option parsing system that I use; also when the help is read carefully, it should be clear. That's why I consider it outside the scope of disper, sorry. This holds for the problem with the single dash, as well as the equal sign.

That the error about the garbage metamode occurs is a more serious problem though; this should not happen just because of a small mistake. I'll have to test it with a multiple monitor setup to see if this problem occurs more generally.
Also display names could be checked before disper executes anything, that would be a good idea.

From here this bug will focus on the garbage metamode problem, and possible validation of display names.

Changed in disper:
assignee: nobody → wvengen (wvengen)
importance: Undecided → Wishlist
status: New → Confirmed
John Coulter (raztus) wrote :

I was getting the same error about garbage metamode, and believe it may have been related to the following metamode in my xorg.conf:

Option "metamodes" "nvidia-auto-select +0+0"

This was set by default when I installed the nvidia proprietary drivers. I went into the nvidia-settings and enabled my laptop display, setting the resolution to its native one rather than "auto". Now my xorg.conf has the following:

Option "metamodes" "DFP-0: 1920x1080 +0+0"

I've yet to see the garbage metamode again. Perhaps it is coincidence, but I'll continue to watch it.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers