Not recognizing monitor pluged to dockin station

Bug #493979 reported by Daniel Castro on 2009-12-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
disper
Medium
Unassigned

Bug Description

Hello!

I have a Thinkpad T61p and use a dockin station with it when I'm at my desk. I like to use cloned configuration at 1680x1050. My nvidia drivers (180.44) handle this very well when X starts.
I installed disper and it works great if I plug a monitor or projector to the laptop's vga port, but when I put my laptop in the dockin station and try to either clone or extend it will not recognize the connected monitor.
Let me know if there are any logs we need from me.

Thanks!

wvengen (wvengen) wrote :

Hi Daniel, thanks for your bug report. Could you please include the following:
  * Your disper version (disper --version)
  * The file created by nvidia-bug-report.sh (which is included by the Ubuntu package nvidia-glx-*).
     If you're running a different distribution, please include /var/log/Xorg.0.log and dmesg.
  * the output of: disper -v -l

Daniel Castro (castromd) wrote :

Hi!

Here you go.

Thanks!

danicast@danicast-ubuntu:~$ disper --version
disper 0.2.3

danicast@danicast-ubuntu:~$ disper -v -l
backend: nVidia
auto-detected displays: DFP-0, CRT-0
resolutions of DFP-0: 576x432, 640x480, 720x450, 640x512, 800x512, 840x525, 1152x864, 1280x960, 1440x900, 1280x1024, 1600x1024, 1680x1050
display DFP-0: IBM
 resolutions: 576x432, 640x480, 720x450, 640x512, 800x512, 840x525, 1152x864, 1280x960, 1440x900, 1280x1024, 1600x1024, 1680x1050
resolutions of CRT-0: 320x240, 400x300, 512x384, 680x384, 640x480, 720x450, 700x525, 840x525, 800x600, 960x540, 832x624, 960x600, 1024x768, 1152x864, 1360x768, 1280x960, 1440x900, 1280x1024, 1400x1050, 1600x1200, 1920x1080, 1920x1200, 1680x1050
display CRT-0: ViewSonic VA2216w-4
 resolutions: 320x240, 400x300, 512x384, 680x384, 640x480, 720x450, 700x525, 840x525, 800x600, 960x540, 832x624, 960x600, 1024x768, 1152x864, 1360x768, 1280x960, 1440x900, 1280x1024, 1400x1050, 1600x1200, 1920x1080, 1920x1200, 1680x1050

wvengen (wvengen) wrote :

Hi Daniel, thanks for the info. Just to be sure: was this info taken with your docking station active, and the vga port on your laptop disconnected? And if you run nvidia-settings, does it detect the docking station's monitor? If so, what display name does it have (DVI-0, CRT-1, or something like that)? Can you enable it from nvidia-settings?

Daniel Castro (castromd) wrote :

Sorry for the big delay!

So yes the docking station was active and the vga port disconnected.

Yes, nvidia settings detect the monitor and the display name is CRT-0. And yes it can be enabled from nvidia settings.

Anything else you need let me know.

wvengen (wvengen) wrote :

Thanks for reporting. This is what I feared ... I'm doing things a little different from nvidia-settings, but it's probable that disper's implementation is not fully complete. This will require quite some work in studying nvidia documentation and nvidia-settings source, and implementing it in disper again. Don't hold your breath just yet, but I'll try to look into it somewhere in the future.

Changed in disper:
importance: Undecided → Medium
status: New → Confirmed
Daniel Castro (castromd) wrote :

Thanks excellent news. I'll wait until then. Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers