Null characters in "disper -l" output

Bug #337721 reported by Jeroen Hoek on 2009-03-04
2
Affects Status Importance Assigned to Milestone
disper
Medium
wvengen

Bug Description

Running "disper -l" produces a list of displays with their resolutions as expected. However, on my laptop the display names are both suffixed with a null character. This causes command line tools to treat the output as binary data.

Suggested solution:
Strip null characters from the display name.

Attached is the output as seen on my laptop. After "DFP-0: CMO" and "DFP-1: Iiyama PLE2208HDS" there is a byte with the value of 0 right before the newline, causing grep and such to complain.

disper 0.2.1

Thanks for creating disper! It is quite useful.

Related branches

Jeroen Hoek (mail-jeroenhoek) wrote :
wvengen (wvengen) wrote :

Thanks for your bug report. I cannot reproduce it here. Could you please attach the EDID of your DFP-0 device? That can be obtained using nvidia-settings by selecting GPU-0->DFP-0 in the list at the left and pressing the button "Acquire EDID...".

Changed in disper:
assignee: nobody → wvengen
status: New → Incomplete
Jeroen Hoek (mail-jeroenhoek) wrote :

Sure thing. Here they are.

Jeroen Hoek (mail-jeroenhoek) wrote :
Jeroen Hoek (mail-jeroenhoek) wrote :

Other version info that might be useful:

Ubuntu 8.10
Python 2.5.2
X.org 7.4
NVidia drivers are at 177.82

Feel free to contact me if you want to test something.

wvengen (wvengen) wrote :

Found the problem and fixed in trunk. Next release will contain the fix.

Changed in disper:
importance: Undecided → Medium
milestone: none → 0.2.2
status: Incomplete → Fix Committed
Jeroen Hoek (mail-jeroenhoek) wrote :

I added the extra check in nvctrl.py and removed the two lines in nvcmd.py like you did in trunk; the output is clean now on my laptop.

Bedankt voor de snelle reactie.

wvengen (wvengen) on 2009-04-09
Changed in disper:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers