YAML error

Bug #1770808 reported by vpc on 2018-05-12

This bug report will be marked for expiration in 48 days if no further activity occurs. (find out why)

6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
diskimage-builder
Undecided
Unassigned

Bug Description

2018-05-12 07:37:18.297 | + pip2 install -q --upgrade -r /tmp/in_target.d/requirements.txt -c /tmp/in_target.d/upper-constraints.txt
2018-05-12 07:38:56.665 | Cannot uninstall 'netaddr'. It is a distutils installed project and thus we cannot accurately determine which files belong to it which would lead to only a partial uninstall.
2018-05-12 07:38:56.736 | ++ /usr/local/lib/python2.7/dist-packages/diskimage_builder/lib/img-functions:run_in_target:59 : check_break after-error run_in_target bash
2018-05-12 07:38:56.742 | ++ /usr/local/lib/python2.7/dist-packages/diskimage_builder/lib/common-functions:check_break:123 : egrep -e '(,|^)after-error(,|$)' -q
2018-05-12 07:38:56.743 | ++ /usr/local/lib/python2.7/dist-packages/diskimage_builder/lib/common-functions:check_break:123 : echo ''
2018-05-12 07:38:56.746 | + /usr/local/lib/python2.7/dist-packages/diskimage_builder/lib/img-functions:run_in_target:1 : trap_cleanup
2018-05-12 07:38:56.748 | + /usr/local/lib/python2.7/dist-packages/diskimage_builder/lib/img-functions:trap_cleanup:36 : exitval=1
2018-05-12 07:38:56.750 | + /usr/local/lib/python2.7/dist-packages/diskimage_builder/lib/img-functions:trap_cleanup:37 : cleanup
2018-05-12 07:38:56.752 | + /usr/local/lib/python2.7/dist-packages/diskimage_builder/lib/img-functions:cleanup:42 : dib-block-device umount
2018-05-12 07:38:56.770 | Traceback (most recent call last):
2018-05-12 07:38:56.770 | File "/usr/local/bin/dib-block-device", line 6, in <module>
2018-05-12 07:38:56.770 | from diskimage_builder.block_device.cmd import main
2018-05-12 07:38:56.771 | File "/usr/local/lib/python2.7/dist-packages/diskimage_builder/block_device/cmd.py", line 19, in <module>
2018-05-12 07:38:56.771 | import yaml
2018-05-12 07:38:56.772 | ImportError: No module named yaml

Ian Wienand (iwienand) wrote :

We probably have multiple things going on here

+ pip2 install -q --upgrade -r /tmp/in_target.d/requirements.txt -c /tmp/in_target.d/upper-constraints.txt
2018-05-12 07:38:56.665 | Cannot uninstall 'netaddr'. It is a distutils installed project and thus we cannot accurately determine which files belong to it which would lead to only a partial uninstall.

This is what raised the error ^. I'm not sure where that came from, as the log before that is truncated, but it's related to pip10.

Then you've got the yaml error, which suggests that you're not running this from an environment with pyyaml installed. see the instructions at https://docs.openstack.org/diskimage-builder/latest/user_guide/installation.html about setting up an environment to run.

Please run with "-x" and "--logfile" and attach a full log if this needs further investigation

Changed in diskimage-builder:
status: New → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers