gentoo builds timing out: sudo not found

Bug #1766484 reported by Ian Wienand on 2018-04-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
diskimage-builder
Undecided
Matthew Thode

Bug Description

Gentoo builds appear to be failing with

---
2018-04-23 19:42:57.072 | /tmp/in_target.d/install.d/01-nodepool-setup: line 1: sudo: command not found
2018-04-23 19:42:57.073 | /tmp/in_target.d/install.d/01-nodepool-setup: line 3: sudo: command not found
---

See [1]. The last good build I can find is [2] where I don't see output (which is weird too)

---
2018-04-17 07:08:11.166 | dib-run-parts 00-up-to-date completed
2018-04-17 07:08:11.166 | dib-run-parts Running /tmp/in_target.d/install.d/01-nodepool-setup
2018-04-17 07:08:11.194 | dib-run-parts 01-nodepool-setup completed
---

Strictly, I don't think these calls need sudo. However, has sudo somehow gone missing in the images

Note this is coming from [3] which doesn't appear to have changed in this regard

[1] http://logs.openstack.org/31/563731/2/check/nodepool-functional-py35-gentoo-src/2254320/controller/logs/builds/gentoo-17-0-systemd-0000000001_log.txt.gz#_2018-04-23_19_42_57_072
[2] http://logs.openstack.org/79/561479/10/check/nodepool-functional-py35-gentoo-src/b730698/controller/logs/builds/gentoo-17-0-systemd-0000000001_log.txt.gz#_2018-04-17_07_08_11_166
[3] https://git.openstack.org/cgit/openstack-infra/nodepool/tree/devstack/plugin.sh#n93

Ian Wienand (iwienand) on 2018-04-24
Changed in diskimage-builder:
assignee: nobody → Matthew Thode (prometheanfire)
Matthew Thode (prometheanfire) wrote :

We don't include sudo in are stage3/4.

sounds like we just need to add it to our package-installs.yaml like suse has

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers