ppc64le tests fail on Fedora due to difference in arch labels

Bug #1744944 reported by Tim Flink on 2018-01-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
diskimage-builder
Undecided
Ian Wienand

Bug Description

During the tests submitted by IBM PowerKVM CI for https://review.openstack.org/#/c/536759, the test for fedora failed when it tried to install dmidecode.

dmidecode isn't a valid package for ppc64(le) and the element calling for it (ironic-agent) does have logic which says that lshw should be used for ppc64 and ppc64el - the problem is that the arch name for PPC64 little endian in Fedora is ppc64le instead of ppc64el which is used for Debian based distros.

Fix the ironic-agent so that it installs lshw instead of dmidecode when the arch is ppc64le.

Fix proposed to branch: master
Review: https://review.openstack.org/536852

Changed in diskimage-builder:
assignee: nobody → Tim Flink (tflink)
status: New → In Progress
Changed in diskimage-builder:
assignee: Tim Flink (tflink) → Ian Wienand (iwienand)

Reviewed: https://review.openstack.org/536852
Committed: https://git.openstack.org/cgit/openstack/diskimage-builder/commit/?id=f8bcc51b554bd26fe0a184432b2ad5d4f79f05b0
Submitter: Zuul
Branch: master

commit f8bcc51b554bd26fe0a184432b2ad5d4f79f05b0
Author: Tim Flink <email address hidden>
Date: Tue Jan 23 15:14:54 2018 +0100

    Don't install dmidecode on Fedora ppc64le

    While Debian-based distros use the label of ppc64el for ppc64 little
    endian, Fedora uses ppc64le.

    The ironic-agent was doing arch specific package install of lshw over
    dmidecode for ppc64 and ppc64el but was attempting to install dmidecode
    on Fedora ppc64le which caused the test to fail due to a missing
    package.

    This change just adds ppc64le to the arch-specific package installation
    description for the ironic-agent element.

    Change-Id: I38c3c1480bbbb2df817856614e6b740a0c02723a
    Closes-Bug: 1744944

Changed in diskimage-builder:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers