Handle networkx 2.0 update

Bug #1718576 reported by Ian Wienand on 2017-09-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mistral
High
Unassigned
OpenStack Global Requirements
Fix Released
Undecided
Matthew Thode
Solar
Undecided
Rajat Sharma
Vitrage
In Progress
High
Anna Reznikov
diskimage-builder
High
Tony Breeds
taskflow
High
Matthew Thode
watcher
High
Alexander Chadin

Bug Description

networkx 2.0 has been released, but is backwards incompatible with the 1.0 versions. Code needs to be ported to the new release

This is for tracking this to remove the constraints

Projects that wish to test with the new networkx can create a gerrit review depending on https://review.openstack.org/505973

Depends-On: I1d13dd20bcbb68e6d46d795e0f6e1440cdd60377

Ian Wienand (iwienand) on 2017-09-21
Changed in diskimage-builder:
status: New → Confirmed
importance: Undecided → High
Matthew Thode (prometheanfire) wrote :

Projects that want to test their code with the new networkx can use the following review

I1d13dd20bcbb68e6d46d795e0f6e1440cdd60377

https://review.openstack.org/505973

description: updated
Ian Wienand (iwienand) wrote :
Rajat Sharma (tajar29) on 2017-10-10
Changed in vitrage:
assignee: nobody → Rajat Sharma (tajar29)
Changed in solar:
assignee: nobody → Rajat Sharma (tajar29)

Fix proposed to branch: master
Review: https://review.openstack.org/515625

Changed in solar:
status: New → In Progress
Anna Reznikov (annarez) on 2017-10-30
Changed in vitrage:
assignee: Rajat Sharma (tajar29) → Anna Reznikov (annarez)
Changed in mistral:
milestone: none → queens-3
Matthew Thode (prometheanfire) wrote :

Requirement.parse('networkx<2.0,>=1.10'), {'pypowervm'})
Requirement.parse('networkx<2.0,>=1.10'), {'diskimage-builder'})
Requirement.parse('networkx<2.0,>=1.10'), {'taskflow'})

we don't control the pypowervm project unfortunately, but diskimagebuilder and taskflow should still start.

Matthew Edmonds (edmondsw) wrote :

It looks like taskflow is the real issue here. It is relying on the nodes_iter method that was removed in networkx 2.0. See https://networkx.github.io/documentation/stable/release/release_2.0.html?highlight=nodes_iter for how to do that with networkx 2.0.

There may be other issues that also need to be addressed. See https://networkx.github.io/documentation/stable/release/migration_guide_from_1.x_to_2.0.html

Changed in mistral:
milestone: queens-3 → rocky-1

Fix proposed to branch: master
Review: https://review.openstack.org/544233

Changed in vitrage:
status: New → In Progress
Anna Reznikov (annarez) wrote :

I tagged my fix in Vitrage as 'partial-bug' because it fixes the bug for now, but we don't have tempest test with networx 2.0 yet, so if anyone pushes code that isn't compatible with networx 2.0 the bug returns.

We try to avoid running all tempest tests twice as it's time consuming. If anyone has a solution for this problem (other than supporting only networx 2.0) in theirs project, I would love to hear about it.

In the future we hope to support only networkx 2.0 (with versioning) and then the bug will be closed completely.

Changed in watcher:
assignee: nobody → Alexander Chadin (joker946)

Reviewed: https://review.openstack.org/544233
Committed: https://git.openstack.org/cgit/openstack/vitrage/commit/?id=457c55d8a2b25924988441dc921a4ff884968023
Submitter: Zuul
Branch: master

commit 457c55d8a2b25924988441dc921a4ff884968023
Author: Anna <email address hidden>
Date: Wed Feb 14 10:13:49 2018 +0000

    adding support for networkx 2.0

    Change-Id: Ieced246b384b6a4be52583007ffbf3f767e18673
    Partial-Bug: #1718576

Fix proposed to branch: master
Review: https://review.openstack.org/544887

Changed in watcher:
status: New → In Progress
Changed in watcher:
importance: Undecided → High

Reviewed: https://review.openstack.org/544887
Committed: https://git.openstack.org/cgit/openstack/watcher/commit/?id=c81cd675a54c535f4d7af628622e529e7e7804a2
Submitter: Zuul
Branch: master

commit c81cd675a54c535f4d7af628622e529e7e7804a2
Author: Alexander Chadin <email address hidden>
Date: Thu Feb 15 15:17:28 2018 +0300

    Add support for networkx v2.0

    Closes-Bug: #1718576
    Change-Id: I1628e4c395591b87c7993294c065476a1f8191bb

Changed in watcher:
status: In Progress → Fix Released
Dougal Matthews (d0ugal) on 2018-04-06
Changed in mistral:
status: New → Triaged
Dougal Matthews (d0ugal) on 2018-04-12
Changed in mistral:
importance: Undecided → High

This issue was fixed in the openstack/watcher 1.9.0 release.

Dougal Matthews (d0ugal) on 2018-04-20
Changed in mistral:
milestone: rocky-1 → rocky-2
Ben Nemec (bnemec) on 2018-05-10
Changed in taskflow:
status: New → Confirmed
importance: Undecided → High

Fix proposed to branch: master
Review: https://review.openstack.org/568910

Changed in diskimage-builder:
assignee: nobody → Matthew Thode (prometheanfire)
status: Confirmed → In Progress
Changed in taskflow:
assignee: nobody → Matthew Thode (prometheanfire)
Changed in openstack-requirements:
assignee: nobody → Matthew Thode (prometheanfire)
Changed in mistral:
assignee: nobody → Matthew Thode (prometheanfire)
status: Triaged → In Progress
Changed in taskflow:
status: Confirmed → In Progress
Changed in openstack-requirements:
status: New → In Progress

Change abandoned by Matthew Thode (<email address hidden>) on branch: master
Review: https://review.openstack.org/568911
Reason: use https://review.openstack.org/#/c/567974/

Changed in diskimage-builder:
assignee: Matthew Thode (prometheanfire) → Ian Wienand (iwienand)

Reviewed: https://review.openstack.org/568908
Committed: https://git.openstack.org/cgit/openstack/taskflow/commit/?id=4607f68ae73ebbe7296f16c7dff2fde1884ce947
Submitter: Zuul
Branch: master

commit 4607f68ae73ebbe7296f16c7dff2fde1884ce947
Author: Matthew Thode <email address hidden>
Date: Wed May 16 12:30:06 2018 -0500

    Uncap networkx

    Change-Id: I1bfa313531175dc218e015c3aabd0a8694e2a635
    Closes-Bug: #1718576

Changed in taskflow:
status: In Progress → Fix Released
Dougal Matthews (d0ugal) on 2018-06-07
Changed in mistral:
assignee: Matthew Thode (prometheanfire) → nobody
milestone: rocky-2 → rocky-3
Ifat Afek (ifat-afek) on 2018-06-18
Changed in vitrage:
importance: Undecided → High

This issue was fixed in the openstack/taskflow 3.2.0 release.

Changed in diskimage-builder:
assignee: Ian Wienand (iwienand) → Tony Breeds (o-tony)

Change abandoned by Ian Wienand (<email address hidden>) on branch: master
Review: https://review.openstack.org/506524
Reason: we had to squash this into I82dc61fac6c156a4f0d574290c7632077aa53195

Changed in openstack-requirements:
status: In Progress → Fix Released
Dougal Matthews (d0ugal) on 2018-08-08
Changed in mistral:
milestone: rocky-3 → stein-1

Change abandoned by Matthew Thode (<email address hidden>) on branch: master
Review: https://review.openstack.org/568910
Reason: this was done already

Dougal Matthews (d0ugal) on 2018-11-19
Changed in mistral:
milestone: stein-1 → stein-2
Changed in mistral:
milestone: stein-2 → none
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.