built ubuntu iso image failed as processing package grub-efi-amd64 has error

Bug #1491280 reported by Ye-hong Fang on 2015-09-02
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
diskimage-builder
Medium
zhangjian

Bug Description

Disk Command:
bin/disk-image-create -a amd64 -o ubuntu-ipa-0612 ubuntu iso 2>&1 | tee log-ubuntu-ipa-0612

Built for ubuntu 14.04 LTS

Issue phenomenon:
Creating config file /etc/default/grub with new version
/usr/sbin/grub-probe: error: cannot find a device for / (is /dev mounted?).
dpkg: error processing package grub-efi-amd64 (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of grub-efi-amd64-signed:
 grub-efi-amd64-signed depends on grub-efi-amd64 (= 2.02~beta2-9ubuntu1.2); however:
  Package grub-efi-amd64 is not configured yet.

dpkg: error processing package grub-efi-amd64-signed (--configure):
 dependency problems - leaving unconfigured
/bin/df: cannot read table of mounted file systems: No such file or directory No apport report written because the error message indicates its a followup error from a previous failure.
Errors were encountered while processing:
 grub-efi-amd64
 grub-efi-amd64-signed

Changed in diskimage-builder:
status: New → In Progress
assignee: nobody → Ye-hong Fang (hongyefang)
tags: added: building image iso
Changed in diskimage-builder:
assignee: Ye-hong Fang (hongyefang) → Ligong Duan (duanlg)
Changed in diskimage-builder:
importance: Undecided → Medium

Fix proposed to branch: master
Review: https://review.openstack.org/244475

Changed in diskimage-builder:
assignee: Ligong Duan (duanlg) → zhangjian (jian-zhang8)

Change abandoned by Jane.zhang (<email address hidden>) on branch: master
Review: https://review.openstack.org/244475

Reviewed: https://review.openstack.org/219612
Committed: https://git.openstack.org/cgit/openstack/diskimage-builder/commit/?id=7eb70becd3c91d0fdf411aeddc93d156d2fa2ecf
Submitter: Jenkins
Branch: master

commit 7eb70becd3c91d0fdf411aeddc93d156d2fa2ecf
Author: Jane.zhang <email address hidden>
Date: Sun Nov 15 23:39:07 2015 -0800

    Fix grub-efi-amd64-signed install failure

    When build ubuntu iso image, it will install grub-efi-amd64-signed
    and grub-efi-amd64 packages. Both of the postinst script will try
    to find root device and install grub which will definitely fail in
    such a chroot environment.
    So the workaround is to skip error and remove postinst script.
    And confirm the package be installed successfully at last.

    Change-Id: Ie0aecb212b22362046db55b5ad8c64c3211c28e5
    Closes-Bug: #1491280
    Co-Authored-By: Jane.zhang <email address hidden>

Changed in diskimage-builder:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers