failed to remove `/tmp/image.A2aupYJb/mnt/tmp/in_target.d': Device or resource busy

Bug #1332521 reported by Dmitry Tantsur on 2014-06-20
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
diskimage-builder
High
Haomeng,Wang

Bug Description

Hi! I encountered the following bug in our gate job:

2014-06-20 12:04:50.486 | dib-run-parts Fri Jun 20 12:04:50 UTC 2014 99-apt-get-update completed
2014-06-20 12:04:50.486 | ----------------------- PROFILING -----------------------
2014-06-20 12:04:50.486 |
2014-06-20 12:04:50.487 | Target: pre-install.d
2014-06-20 12:04:50.487 |
2014-06-20 12:04:50.487 | Script Seconds
2014-06-20 12:04:50.487 | --------------------------------------- ----------
2014-06-20 12:04:50.487 |
2014-06-20 12:04:50.507 | 99-apt-get-update 3.629
2014-06-20 12:04:50.526 | 04-dib-init-system 0.005
2014-06-20 12:04:50.542 | 03-baseline-tools 7.882
2014-06-20 12:04:50.559 | 02-add-apt-keys 0.002
2014-06-20 12:04:50.572 | 01-set-ubuntu-mirror 0.002
2014-06-20 12:04:50.586 | 01-dpkg-install-bin 0.005
2014-06-20 12:04:50.600 | 00-remove-grub 0.023
2014-06-20 12:04:50.616 | 00-remove-apt-xapian-index 1.960
2014-06-20 12:04:50.631 | 00-disable-apt-recommends 0.003
2014-06-20 12:04:50.632 |
2014-06-20 12:04:50.632 | --------------------- END PROFILING ---------------------
2014-06-20 12:04:50.645 | rmdir: failed to remove `/tmp/image.A2aupYJb/mnt/tmp/in_target.d': Device or resource busy
2014-06-20 12:04:50.666 | rm: cannot remove `/tmp/image.A2aupYJb': Device or resource busy
2014-06-20 12:04:50.666 | + exit_trap

All logs: http://logs.openstack.org/21/73121/10/check/check-tempest-dsvm-virtual-ironic/d77e6c7/

Ben Nemec (bnemec) on 2014-07-07
Changed in diskimage-builder:
status: New → Triaged
importance: Undecided → High
Ghe Rivero (ghe.rivero) on 2014-10-15
Changed in diskimage-builder:
assignee: nobody → Ghe Rivero (ghe.rivero)
Ghe Rivero (ghe.rivero) wrote :

I cannot find any recent reference/occurence of this bug neither here or in the Ironic project, and I haven't been able to reproduce it (even using the repository status around the day this was reported)

Dmitry Tantsur (divius) wrote :

Well, let's call it fixed.

Changed in diskimage-builder:
status: Triaged → Invalid
Haomeng,Wang (whaom) wrote :

I can recreated this issue, the root cause is after umount called, it return 0, but the mounted dev is not released, the resource is still in busy status, so we can add more sleep before the 'rmdir' command call.

Changed in diskimage-builder:
assignee: Ghe Rivero (ghe.rivero) → Haomeng,Wang (whaom)
status: Invalid → In Progress

Reviewed: https://review.openstack.org/137737
Committed: https://git.openstack.org/cgit/openstack/diskimage-builder/commit/?id=cc9870ec1142cc46fd3e2e84a2d2e38c78d57d60
Submitter: Jenkins
Branch: master

commit cc9870ec1142cc46fd3e2e84a2d2e38c78d57d60
Author: Haomeng, Wang <email address hidden>
Date: Mon Mar 23 08:35:41 2015 +0000

    Try 5 times for rmdir command call after umount

    Sometime, we will get "Device or resource busy" during the mount point
    deleting, umount return 0, but the resouce is busy for a while, so need
    to add sleep interval to wait resource free, then we can delete it.
    Change-Id: Idaa219d12e847824960eec8907739add5d619d1a
    Closes-Bug: 1332521

Changed in diskimage-builder:
status: In Progress → Fix Committed
Jay Dobies (jdob) on 2015-05-11
Changed in diskimage-builder:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers