build stops at Extracting libaudit-common...

Bug #1274785 reported by Geo_KM on 2014-01-31
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
diskimage-builder
Medium
Unassigned

Bug Description

Hi

I have sucessfully built Fedora and Ubuntu images on my Centos 6.5 based system using diskimage-builder. Great tool.

Now trying to create debian images and it just stops dead at I: Extracting libaudit-common...
I have installed debbootstrap.

The command I am using is

bin/disk-image-create -a i386 -o test debian vm

same result for -a amd64

I guess this could be a debbootstrap issue actually, but are you able to replicate the problem.?
In which case it is a problem for diskimage-builer too 8-(

Thanks.

Tomas Sedovic (tsedovic) wrote :

I've just tried this on RHEL 6.5 (which should be pretty much the same thing) and I got a different error (couldn't find "/usr/share/debootstrap/scripts/unstable").

Can you please update to the latest diskimage-builder version, try again and attach the full output here?

Changed in diskimage-builder:
status: New → Incomplete

Hi Tomas,

Yeah had that error at first too. It seems debbootstrap on RHEL/Centos
does not have the unstable link to sid.

I just created a link in /usr/share/debootstrap/scripts/ to sid (which
is the unstable distro anyway) and that overcame that little problem.

I have attached the output from the next step so you can see the error I
get. Or in fact lack of error...... It just stops dead on Extracting
libaudit-common...

weird.

On 05/02/14 02:34, Tomas Sedovic wrote:
> I've just tried this on RHEL 6.5 (which should be pretty much the same
> thing) and I got a different error (couldn't find
> "/usr/share/debootstrap/scripts/unstable").
>
> Can you please update to the latest diskimage-builder version, try again
> and attach the full output here?
>
>
> ** Changed in: diskimage-builder
> Status: New => Incomplete
>

--
oooOOOooo
Regards......Geo

Changed in diskimage-builder:
status: Incomplete → Triaged
importance: Undecided → Medium
Stephane Miller (stephaneeee) wrote :

CentOS 6 doesn't include python 2.7, and I don't see this error in CentOS 7. I'm closing this bug.

Changed in diskimage-builder:
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers