Does not work with Java applications and has issues with vnc

Bug #884375 reported by Andrew on 2011-10-31
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Diodon
Medium
Oliver Sauder

Bug Description

When I have diodon loaded, I cannot copy text, either via the primary selection, or the clipboard in java (Oracle JDev IDE). If I shut down diodon, it starts working again.

I have also seen similar issues when trying to use clipboard transfers with remmina (vnc client).

I really like diodon and its integration with unity, but this bug really makes it difficult to work.

dlocate -s diodon
Package: diodon
Status: install ok installed
Priority: optional
Section: utils
Installed-Size: 324
Maintainer: Diodon Team <email address hidden>
Architecture: amd64
Version: 0.6.0-0ubuntu0~oneiric1
Depends: libdiodon0 (= 0.6.0-0ubuntu0~oneiric1), dconf-gsettings-backend | gsettings-backend, libappindicator3-1 (>= 0.2.92), libc6 (>= 2.3.4), libglib2.0-0 (>= 2.26), libgtk-3-0 (>= 3.0.0), libpeas-1.0-0 (>= 1.0.0), libunique-3.0-0 (>= 2.90.1)
Suggests: diodon-plugins (= 0.6.0-0ubuntu0~oneiric1)
Conffiles:
 /etc/xdg/autostart/diodon.desktop 797eccb9fff265c3842e78812a7c8015
Description: GTK+ Clipboard manager
 Diodon is a lightweight clipboard manager for Linux written in Vala which
 "aims to be the best integrated clipboard manager for the Gnome/Unity desktop".
 .
 Diodon features include Ubuntu indicator, clipboard sync (primary selection
 and Ctrl+C / Ctrl+V clipboard) and an option to set the clipboard size.
Homepage: https://launchpad.net/diodon

Oliver Sauder (sao) wrote :

I've tried to reproduce this issue however haven't been successful so far ;).

I have to sign up to get JDev therefore I did some testing with jedit and soapui. When diodon is closed the primary selection is not working either in those Java Applications. So this seems to be a general issue with Java Applications.

However Ctrl+C works as expected. But it does work without any problem on my system as well when Diodon is started.

So before I download myself JDev could you quickly test whether JEdit works together with Diodon on your system? It might be a JDev specific error.

Andrew (andrew-rw-robinson) wrote :

Okay, in jEdit, with diodon open:
I cannot highlight in jEdit and paste into gnome-terminal (middle-mouse)
I cannot ctrl+c in in jEdit and paste into gnome-terminal
I cannot ctrl+insert in in jEdit and paste into gnome-terminal

After closing diodon:
I can highlight in jEdit and paste into gnome-terminal (middle-mouse)
I cannot ctrl+c in in jEdit and paste into gnome-terminal
I cannot ctrl+insert in in jEdit and paste into gnome-terminal

Note that I use a Dvorak keyboard layout and usually use ctrl+insert to copy instead of ctrl+c

Andrew (andrew-rw-robinson) wrote :

Okay, running:
/usr/lib/jvm/java-6-openjdk/demo/jfc/FileChooserDemo$ java -jar FileChooserDemo.jar

In there, if I open the file chooser and select a file, then using the "File Name:" input text to copy and highlight text,

I still cannot paste ctrl+c/insert into gnome terminal, but I found that everything works when pasting into gvim.

Not sure if gnome has a different clipboard storage than what gvim uses? Very odd, but I am not too shocked knowing linux's complexity of clipboard apis.

Oliver Sauder (sao) wrote :

I cannot paste from jedit into Gnome Terminal either no matter whether Diodon is running or not. On the other hand, jedit to gedit always works.

When selecting a text in jedit and using middle mouse click to paste it into the gnome terminal works well even when Diodon is running.
However it seems that when selecting or copying a text from jedit such item does not appear in the Diodon history.

Therefore marking this bug as confirmed.

Changed in diodon:
status: New → Confirmed
Oliver Sauder (sao) wrote :

Strange. On my office computer running Lucid I can reproduce the issue.

Changed in diodon:
importance: Undecided → Medium
milestone: none → 0.7.0
Oliver Sauder (sao) on 2011-11-17
Changed in diodon:
status: Confirmed → In Progress
assignee: nobody → Oliver Sauder (sao)
Oliver Sauder (sao) wrote :

It seems some applications store text in the clipboard but the clipboard tells me that there isn't any. However when checking there is.... ;).

Added a workaround for this. Should be available for testing in the daily ppa soon.

Oliver Sauder (sao) on 2011-11-18
Changed in diodon:
status: In Progress → Fix Committed
Oliver Sauder (sao) on 2012-01-04
Changed in diodon:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers