auto-paste doesn't work on gtk3 applications

Bug #875708 reported by Chow Loong Jin on 2011-10-16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Oliver Sauder

Bug Description

Steps to reproduce:
1. Open Diodon preferences and make sure "Automatically paste selected item" is checked.
2. Focus the terminal and press Ctrl+Alt+V (Diodon shortcut)
3. Select something to paste
4. Nothing happens.

Chow Loong Jin (hyperair) wrote :

Okay, it seems to not function in gtk-3 using applications? Though it does work in Firefox.

Oliver Sauder (sao) wrote :

Well, this seems to be a regression. Could reproduce the issue that instant paste does not work on gtk3 application.

Changed in diodon:
status: New → Confirmed
importance: Undecided → High
Oliver Sauder (sao) on 2011-10-18
Changed in diodon:
milestone: none → 0.6.0
Oliver Sauder (sao) on 2011-10-19
Changed in diodon:
status: Confirmed → In Progress
assignee: nobody → Oliver Sauder (sao)
Oliver Sauder (sao) wrote :

I have replaced the XSendKey event with XTestFakeKeyEvent. See otherwise for more details.

This way the gtk3 applications accept the sent keys as well.

Ready for testing in daily ppa when following build is done.

summary: - auto-paste doesn't work in gnome-terminal in Oneiric
+ auto-paste doesn't work on gtk3 applications
Changed in diodon:
status: In Progress → Fix Committed
Oliver Sauder (sao) on 2011-10-29
Changed in diodon:
status: Fix Committed → Fix Released
Vassilis Kehayas (vkehayas) wrote :

It appears that I encountered this error again, however it happens whether auto-paste is selected or not.
My shortcut is <Ctrl><Alt>V, but nothing happens.
I tried in several applications' text boxes, including Chromium and Firefox.
I also tried very fast (see bug, but the menu doesn't appear.

:~$ uname -a
Linux 3.13.0-46-generic #75-Ubuntu SMP Tue Feb 10 15:24:04 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

Ubuntu 14.04.2 LTS with Gnome

Oliver Sauder (sao) wrote :

This has nothing to do with this issue. Please try out new version 1.3.0 and if it still doesn't work please open a new bug report. Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers