Errors with none utf-8 strings

Bug #799923 reported by Oliver Sauder on 2011-06-20
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Diodon
High
Oliver Sauder

Bug Description

Hi,

I use Natty on eee pc with Unity-2d. After about week of good work diodon doesn´t start and doesn´t appear on panel. Submenu on unity launchbar is empty. I can run diodon as superuser and it works well (but menu of sidebar of unity-2d still empty).
When the app starts in terminal I see this:

(diodon:2317): GLib-CRITICAL **: g_variant_new_string: assertion `g_utf8_validate (string, -1, NULL)' failed
(diodon:2317): libunity-DEBUG: unity-place.vala:854: No browser to export

(diodon:2317): dee-CRITICAL **: clone_leader: assertion `self->priv->revision_queue == NULL' failed

(diodon:2317): dee-CRITICAL **: clone_leader: assertion `self->priv->revision_queue == NULL' failed

(diodon:2317): dee-CRITICAL **: clone_leader: assertion `dee_model_get_n_rows (DEE_MODEL (self)) == 0' failed

(diodon:2317): GLib-CRITICAL **: g_variant_new_string: assertion `g_utf8_validate (string, -1, NULL)' failed

(diodon:2317): dee-CRITICAL **: Trying to build a row with a NULL member on position 4. This is probably an error in an application using libdee

(diodon:2317): GLib-CRITICAL **: g_variant_get_type: assertion `value != NULL' failed

(diodon:2317): GLib-CRITICAL **: g_variant_type_equal: assertion `g_variant_type_check (type1)' failed

(diodon:2317): dee-CRITICAL **: dee_sequence_model_set_value_silently: assertion `g_variant_type_equal (g_variant_get_type (value), G_VARIANT_TYPE (dee_model_get_column_schema (self, column)))' failed

(diodon:2317): GLib-CRITICAL **: g_variant_get_type: assertion `value != NULL' failed

(diodon:2317): GLib-CRITICAL **: g_variant_type_equal: assertion `g_variant_type_check (type1)' failed

(diodon:2317): dee-CRITICAL **: dee_sequence_model_set_value_silently: assertion `g_variant_type_equal (g_variant_get_type (value), G_VARIANT_TYPE (dee_model_get_column_schema (self, column)))' failed

(diodon:2317): dee-CRITICAL **: Internal error: Column 4 in DeeSequenceModel@0x975e8a8 holds a NULL value in row 0

(diodon:2317): dee-CRITICAL **: Internal error: Column 5 in DeeSequenceModel@0x975e8a8 holds a NULL value in row 0

(diodon:2317): GLib-CRITICAL **: g_variant_new_variant: assertion `value != NULL' failed

(diodon:2317): GLib-CRITICAL **: g_variant_get_type: assertion `value != NULL' failed

(diodon:2317): GLib-CRITICAL **: g_variant_type_is_subtype_of: assertion `g_variant_type_check (type)' failed

(diodon:2317): GLib-CRITICAL **: g_variant_builder_add_value: assertion `!GVSB(builder)->expected_type || g_variant_is_of_type (value, GVSB(builder)->expected_type)' failed

(diodon:2317): GLib-CRITICAL **: g_variant_new_variant: assertion `value != NULL' failed

(diodon:2317): GLib-CRITICAL **: g_variant_get_type: assertion `value != NULL' failed

(diodon:2317): GLib-CRITICAL **: g_variant_type_is_subtype_of: assertion `g_variant_type_check (type)' failed

(diodon:2317): GLib-CRITICAL **: g_variant_builder_add_value: assertion `!GVSB(builder)->expected_type || g_variant_is_of_type (value, GVSB(builder)->expected_type)' failed
Segmentation failed

Thanks
Pavel

Related branches

Oliver Sauder (sao) wrote :

This is not normal. Therefore I have opened up this bug report.

For better investigation please attach your diodon history located in ~/.local/share/diodon/storage.xml

Download full text (3.8 KiB)

I send the file.
Thanks for quick answer,
Pavel

21 июня 2011, 00:30 от Oliver Sauder <email address hidden>:
> This is not normal. Therefore I have opened up this bug report.
>
> For better investigation please attach your diodon history located in
> ~/.local/share/diodon/storage.xml
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/799923
>
> Title:
> Segmentation fault when starting diodon
>
> Status in Diodon - GTK+ clipboard manager:
> New
>
> Bug description:
> Hi,
>
> I use Natty on eee pc with Unity-2d. After about week of good work diodon
> doesn´t start and doesn´t appear on panel. Submenu on unity launchbar is
> empty. I can run diodon as superuser and it works well (but menu of sidebar of
> unity-2d still empty).
> When the app starts in terminal I see this:
>
> (diodon:2317): GLib-CRITICAL **: g_variant_new_string: assertion
> `g_utf8_validate (string, -1, NULL)' failed
> (diodon:2317): libunity-DEBUG: unity-place.vala:854: No browser to export
>
> (diodon:2317): dee-CRITICAL **: clone_leader: assertion
> `self->priv->revision_queue == NULL' failed
>
> (diodon:2317): dee-CRITICAL **: clone_leader: assertion
> `self->priv->revision_queue == NULL' failed
>
> (diodon:2317): dee-CRITICAL **: clone_leader: assertion
> `dee_model_get_n_rows (DEE_MODEL (self)) == 0' failed
>
> (diodon:2317): GLib-CRITICAL **: g_variant_new_string: assertion
> `g_utf8_validate (string, -1, NULL)' failed
>
> (diodon:2317): dee-CRITICAL **: Trying to build a row with a NULL
> member on position 4. This is probably an error in an application
> using libdee
>
> (diodon:2317): GLib-CRITICAL **: g_variant_get_type: assertion `value
> != NULL' failed
>
> (diodon:2317): GLib-CRITICAL **: g_variant_type_equal: assertion
> `g_variant_type_check (type1)' failed
>
> (diodon:2317): dee-CRITICAL **: dee_sequence_model_set_value_silently:
> assertion `g_variant_type_equal (g_variant_get_type (value),
> G_VARIANT_TYPE (dee_model_get_column_schema (self, column)))' failed
>
> (diodon:2317): GLib-CRITICAL **: g_variant_get_type: assertion `value
> != NULL' failed
>
> (diodon:2317): GLib-CRITICAL **: g_variant_type_equal: assertion
> `g_variant_type_check (type1)' failed
>
> (diodon:2317): dee-CRITICAL **: dee_sequence_model_set_value_silently:
> assertion `g_variant_type_equal (g_variant_get_type (value),
> G_VARIANT_TYPE (dee_model_get_column_schema (self, column)))' failed
>
> (diodon:2317): dee-CRITICAL **: Internal error: Column 4 in
> DeeSequenceModel@0x975e8a8 holds a NULL value in row 0
>
> (diodon:2317): dee-CRITICAL **: Internal error: Column 5 in
> DeeSequenceModel@0x975e8a8 holds a NULL value in row 0
>
> (diodon:2317): GLib-CRITICAL **: g_variant_new_variant: assertion
> `value != NULL' failed
>
> (diodon:2317): GLib-CRITICAL **: g_variant_get_type: assertion `value
> != NULL' failed
>
> (diodon:2317): GLib-CRITICAL **: g_variant_type_is_subtype_of:
> assertion `g_variant_type_check (type)' failed
>
> (diodon:2317): GLib-CRITICAL **: g_variant_builder_add_value:
> assertion `!GVSB(builder)->expected_type || g_variant_is_of_type
> (value, GVSB(builder)->expected_type)'...

Read more...

Hmm, I can reproduce the issue GLib-CRITICAL **: g_variant_new_string: assertion `g_utf8_validate (string, -1, NULL)' failed. However this does not cause Diodon to crash on my system.

What happens when you delete the storage.xml before you start diodon?

It works very well!
Thank you a lot.
Pavel

Oliver Sauder (sao) wrote :

All right. This means we have a problem with none utf-8 strings. Diodon handles such not correctly. This must be fixed.

summary: - Segmentation fault when starting diodon
+ Errors with none utf-8 strings
Changed in diodon:
importance: Undecided → High
status: New → In Progress
assignee: nobody → Oliver Sauder (sao)
Oliver Sauder (sao) wrote :

It turned out that building of the label of an item was error prone and led to invalid UTF-8 strings.

In your case this led than finally to a segmentation fault. This is now fixed in trunk which will be available in the diodon daily ppa soon (however the build farm seems to be used quite heavily so it won't be available before tomorrow)

Could you test this version with the old storage.xml file so we can really be sure that this bug does not occur again? Thanks.

Changed in diodon:
status: In Progress → Fix Committed
Oliver Sauder (sao) on 2011-06-22
Changed in diodon:
milestone: none → 0.4.1
Oliver Sauder (sao) wrote :

So finally the fix is now available in the daily ppa.

Oliver Sauder (sao) on 2011-06-25
Changed in diodon:
milestone: 0.4.1 → 0.5.0
Oliver Sauder (sao) wrote :

Has been now released with version 0.5.0. If you still suffer from a similar issue please file another bug.

Changed in diodon:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Bug attachments