Shortcut to display diodon-menu is not working

Bug #711703 reported by Martin Knoller Stocker on 2011-02-02
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Diodon
Critical
Oliver Sauder

Bug Description

The registered shortcut for the HistoryKey <Ctr><Alt>V does not display the diodon-menu.

Also when changing the shortcut no menu is displayed.

This is the debug output, while switching the shortcut, when diodon is started on the console

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
** (diodon:8274): DEBUG: configuration-manager.vala:135: Value of key /apps/diodon/keybindings/history has changed to <Ctrl><Alt>
** (diodon:8274): DEBUG: keybinding-manager.vala:120: Unbinding key <Ctrl><Alt>V
** (diodon:8274): DEBUG: keybinding-manager.vala:82: Binding key <Ctrl><Alt>
** (diodon:8274): DEBUG: keybinding-manager.vala:109: Successfully binded key <Ctrl><Alt>
** (diodon:8274): DEBUG: configuration-manager.vala:135: Value of key /apps/diodon/keybindings/history has changed to <Ctrl><Alt>H
** (diodon:8274): DEBUG: keybinding-manager.vala:120: Unbinding key <Ctrl><Alt>
** (diodon:8274): DEBUG: keybinding-manager.vala:82: Binding key <Ctrl><Alt>H
** (diodon:8274): DEBUG: keybinding-manager.vala:109: Successfully binded key <Ctrl><Alt>H
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

System: Ubuntu 10.10
Tested on a desktop computer and a laptop

Related branches

Oliver Sauder (sao) wrote :

Could not reproduce this issue even on a freshly installed maverick installation.

So that we can track down the issue a bit further I've created a new branch with some more debug statements.

Do get the new branch installed on your machine follow these steps:
sudo apt-get build-dep diodon
bzr branch lp:~diodon-team/diodon/hotkey-fix
cd hotkey-fix
./waf configure
./waf build
sudo ./waf install

After starting diodon from the console again, check if there are any logging statement when the hotkey is pressed.

(Hint just call sudo ./waf uninstall do uninstall diodon again)

still no output

Oliver Sauder (sao) wrote :

Can now also reproduce the bug. When either NumLock or CapsLock is active, the shortcut is not working.

Changed in diodon:
status: New → Triaged
importance: Undecided → Critical
assignee: nobody → Oliver Sauder (sao)
Oliver Sauder (sao) on 2011-02-05
Changed in diodon:
status: Triaged → In Progress
Oliver Sauder (sao) wrote :

Now all hot keys in combination with either the NumLock, CapsLock or ScrollLock key are grabbed to open the diodon menu.

Fix is committed in trunk (bzr branch lp:diodon).

Can you check it out and test if it is now working?

Changed in diodon:
status: In Progress → Fix Committed

Yes, working like a charm ;) thx for the quick fix

Oliver Sauder (sao) on 2011-02-07
Changed in diodon:
milestone: none → 0.2.1
Oliver Sauder (sao) on 2011-02-07
Changed in diodon:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers