Does not always clear clipboard

Bug #689459 reported by Dariel Dato-on on 2010-12-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Diodon
High
Oliver Sauder

Bug Description

Clicking on the "clear" menu item does not always clear the clipboard.

Steps to reproduce:
1. Make sure diodon is not running
2. Copy text to the clipboard with Ctrl+C
3. Start diodon (the text you copied in step 2 will be in the clipboard)
4. Open the diodon menu and click "clear" (Do NOT click on any of the other clipboard items)
5. The text copied in step 2 will be added back to the clipboard.

Note that once you click on any of the clipboard items in the menu, the "clear" menu item works as expected.

Related branches

description: updated
Oliver Sauder (sao) on 2010-12-17
Changed in diodon:
assignee: nobody → Oliver Sauder (sao)
status: New → In Progress
Oliver Sauder (sao) wrote :

When resetting the clipboard clipboard.set_text("", -1); (currently committed to lp:diodon) your described issue seems to be fixed. But the clipboard is still not cleared and the text which was available before clearing the clipboard can still be pasted anywhere.

Oliver Sauder (sao) wrote :

As partly fixed and not so crucial anymore targeting to milestone 0.2

Changed in diodon:
milestone: 0.1 → 0.2
Oliver Sauder (sao) wrote :

Can not reproduce this issue anymore. It seems when writing Comment #1 I had another clipboard manager running which copied it back to the clipboard again.

Trying to target it back to version 0.1.0 as it has been fixed there.

Changed in diodon:
milestone: 0.2.0 → 0.1.0
status: In Progress → Fix Committed
Oliver Sauder (sao) on 2011-01-05
Changed in diodon:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers