Repeating the keyboard shortccut does not scroll down in the history

Bug #1435032 reported by Thierry on 2015-03-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Diodon
Medium
Unassigned

Bug Description

This may be related to bug 1377490

I have set the keybarod shortcut to: <Ctrl><Alt><Shift>w

I have found that repeating the keyboard shortcut (that is maintaining pressed <Ctrl><Alt><Shift>, and hit 'w' several times), it does show the popup with the history, but it does *not* scroll down the history in the popup.

When I set the keyboard shortcut to the original setting "<Ctrl><Alt>V", this *does* work.

Thierry (thdox) on 2015-03-22
description: updated
Oliver Sauder (sao) on 2015-03-30
Changed in diodon:
status: New → Confirmed
importance: Undecided → Medium
Oliver Sauder (sao) on 2015-06-20
Changed in diodon:
milestone: none → 1.4.0
Oliver Sauder (sao) wrote :

Unfortunately due to instability in the hotkey feature did we need to drop this feature. You can find more details here https://esite.ch/2015/07/using-custom-shortcuts-of-de-as-diodon-hotkey/.

Because of this change doesn't Diodon know anymore what shortcut is being pressed and cannot implement this feature anymore scrolling through the history with the keybinding.

It was a hard decision to make but the hotkey in Diodon just proved to be very instable (as also this issue suggests) so we had to take action. We would like to improve accessibility of the clipboard history. An option might be as explained in Bug #1235825 but if there are any other ideas there are always welcome - best added to that Bug.

Changed in diodon:
status: Confirmed → Fix Committed
Oliver Sauder (sao) on 2015-10-13
Changed in diodon:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers