libdiodon0 doesn't get upgraded correctly

Bug #1347181 reported by Craig Leinoff on 2014-07-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Diodon
High
Oliver Sauder

Bug Description

Added repository ppa:diodon-team/stable (also tried daily) and Diodon installs correctly but will not open:

$ diodon

(diodon:5403): GLib-GIO-ERROR **: Settings schema 'net.launchpad.Diodon.clipboard' does not contain a key named 'clipboard-size'
Trace/breakpoint trap (core dumped)

Ubuntu 14.04 64 bit.

Oliver Sauder (sao) wrote :

What is the output of following command:
which diodon

Oliver Sauder (sao) wrote :

just some more thoughts on this. This error usually occurs when e.g. diodon has be built from source before and it has been cleaned up but some compiled schema files are still around (as this compiled schema files contains other details of other schema as well so it would be criticla to remove it when uninstall from source).

So just check whether there is a file in /usr/local/share/glib-2.0/schemas/gschemas.compiled and if yes delete it.

Does this work for you?

Hi Oliver,

Thanks so much. I do NOT have that file, unfortunately. :( I also don't
believe I (personally) built Diodon from source; I've only installed via
package manager. Although I did install once via the 14.04 repository, I
believe, before uninstalling and trying again via Diodon's.

Per your first message:

$ which diodon
/usr/bin/diodon

Best,
Craig

On Wed, Jul 23, 2014 at 6:46 AM, Oliver Sauder <email address hidden> wrote:

> just some more thoughts on this. This error usually occurs when e.g.
> diodon has be built from source before and it has been cleaned up but
> some compiled schema files are still around (as this compiled schema
> files contains other details of other schema as well so it would be
> criticla to remove it when uninstall from source).
>
> So just check whether there is a file in
> /usr/local/share/glib-2.0/schemas/gschemas.compiled and if yes delete
> it.
>
> Does this work for you?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1347181
>
> Title:
> Diodon will not open, citing lack of "clipboard-size" key in schema
> "net.launchpad.Diodon.clipboard"
>
> Status in Diodon - GTK+ Clipboard Manager:
> New
>
> Bug description:
> Added repository ppa:diodon-team/stable (also tried daily) and Diodon
> installs correctly but will not open:
>
> $ diodon
>
> (diodon:5403): GLib-GIO-ERROR **: Settings schema
> 'net.launchpad.Diodon.clipboard' does not contain a key named
> 'clipboard-size'
> Trace/breakpoint trap (core dumped)
>
> Ubuntu 14.04 64 bit.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/diodon/+bug/1347181/+subscriptions
>

Strange...

OK could you try to run the following command:
sudo glib-compile-schemas /usr/share/glib-2.0/schemas/

and see whether diodon starts now

Yep! That worked! Thanks very much!

And now I'm left only with the original issue that prompted me to download
Diodon via the team repo -- which is that no history key combination I
tried (including ones that work in Parcellite) bring up Diodon's history!
Maybe I'll make a new bug for that.

OK I will need to check why this command has not been run automatically when installing the diodon package so I keep this issue open for now therefore.

About the history combination key see issue https://bugs.launchpad.net/diodon/+bug/1174342 and there is also a workaround stated.

Changed in diodon:
milestone: none → 1.2.0
status: New → Confirmed
Craig Leinoff (craig-leinoff) wrote :

Bravo. Thanks!

Oliver Sauder (sao) on 2014-07-26
Changed in diodon:
status: Confirmed → Triaged
importance: Undecided → High
Oliver Sauder (sao) wrote :

I was able to reproduce this issue.

Seems when the diodon package gets updated from version 1.0.2 to 1.1.0 the glib trigger which calls glib-compile-schemas is not correctly called. This trigger is usually called by dpkg automatically so I am trying to figure out why it doesn't call it.

summary: - Diodon will not open, citing lack of "clipboard-size" key in schema
- "net.launchpad.Diodon.clipboard"
+ glib-compile-schemas not triggered during diodon upgrade
Oliver Sauder (sao) wrote :

This issue had nothing to do with gschemas after all but that diodon did not specifically define a version for libdiodon0 dependency. This way diodon got upgraded but libdiodon0 remained in the old version.

Fixed now and will be available in next Diodon release.

summary: - glib-compile-schemas not triggered during diodon upgrade
+ libdiodon0 doesn't get upgraded correctly
Changed in diodon:
status: Triaged → Fix Committed
assignee: nobody → Oliver Sauder (sao)
Oliver Sauder (sao) on 2014-08-03
Changed in diodon:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers