Diodon - GTK+ Clipboard Manager

Fails to build with --enable-unitylens-plugin

Reported by Jeremy Bicha on 2013-06-09
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Diodon
Medium
Unassigned
diodon (Ubuntu)
Undecided
Unassigned

Bug Description

diodon no longer builds on Ubuntu "Saucy" if --enable-unitylens-plugin is set.

[34/69] libdiodon_typelib: _build_/libdiodon/Diodon-1.0.gir -> _build_/libdiodon/Diodon-1.0.typelib
/usr/share/gir-1.0/Gee-1.0.gir:8:51: warning: element annotation from state 6 is unknown, ignoring
/usr/share/gir-1.0/Gee-1.0.gir:9:53: warning: element annotation from state 6 is unknown, ignoring
[35/69] valac: diodon/main.vala -> _build_/diodon/main.c
/«PKGBUILDDIR»/plugins/unitylens/unity-lens-plugin.vala:41.17-41.26: error: The type name `Unity.Lens' could not be found
/«PKGBUILDDIR»/plugins/unitylens/unity-lens-plugin.vala:42.17-42.27: error: The type name `Unity.Scope' could not be found
/«PKGBUILDDIR»/plugins/unitylens/unity-lens-plugin.vala:181.41-181.51: error: The type name `Unity.Scope' could not be found
/«PKGBUILDDIR»/plugins/unitylens/unity-lens-plugin.vala:182.13-182.28: error: The type name `Unity.LensSearch' could not be found
/«PKGBUILDDIR»/plugins/unitylens/unity-lens-plugin.vala:188.42-188.57: error: The type name `Unity.LensSearch' could not be found
/«PKGBUILDDIR»/plugins/unitylens/unity-lens-plugin.vala:209.48-209.63: error: The type name `Unity.LensSearch' could not be found
/«PKGBUILDDIR»/plugins/unitylens/unity-lens-plugin.vala:221.55-221.70: error: The type name `Unity.LensSearch' could not be found
Waf: Leaving directory `/«PKGBUILDDIR»/_build_'
Build failed
 -> task in 'unitylens' failed (exit status 1):
 {task 37201808: valac unity-lens-plugin.vala,unity-lens-schemas.vala -> unitylens.h,unitylens.vapi,unitylens.deps,unity-lens-plugin.c,unity-lens-schemas.c}
''

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: diodon (not installed)
ProcVersionSignature: Ubuntu 3.9.0-4.9-generic 3.9.4
Uname: Linux 3.9.0-4-generic x86_64
ApportVersion: 2.10.2-0ubuntu1
Architecture: amd64
Date: Sun Jun 9 10:01:31 2013
MarkForUpload: True
SourcePackage: diodon
UpgradeStatus: Upgraded to saucy on 2013-05-07 (32 days ago)

Related branches

lp:~sao/ubuntu/saucy/diodon/new_ext_api_plugins
Merged into lp:ubuntu/saucy/diodon at revision 4
Jeremy Bicha (community): Approve on 2013-07-15
Ubuntu branches: Pending requested 2013-07-06
Jeremy Bicha (jbicha) wrote :
Oliver Sauder (sao) wrote :

Seems that the libunity api has changed.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in diodon (Ubuntu):
status: New → Confirmed
Oliver Sauder (sao) on 2013-06-12
Changed in diodon:
status: New → Confirmed
Jeremy Bicha (jbicha) wrote :

Thank Oliver.

Could you also update your dependency on valac-0.16 (>= 0.16.0) to simply valac (>= 0.16.0) ? This will have your package build against the default valac and will make transitions easier as we'd like to eventually drop vala-0.16 from the Ubuntu archives.

Logan Rosen (logan) on 2013-06-27
tags: added: ftbfs
Oliver Sauder (sao) on 2013-07-13
Changed in diodon:
milestone: none → 1.1.0
importance: Undecided → Medium
status: Confirmed → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package diodon - 1.0.2-0ubuntu2

---------------
diodon (1.0.2-0ubuntu2) saucy; urgency=low

  * Deactivate unitylens-plugin (LP: #1189154)
  * debian/patches/01_port-to-zeitgeist-2.0.patch
    - Port to zeitgeist-2.0 (LP: #1197569)
  * Using valac dependency instead of valac-0.16
 -- Oliver Sauder <email address hidden> Sun, 14 Jul 2013 23:58:19 +0300

Changed in diodon (Ubuntu):
status: Confirmed → Fix Released
Oliver Sauder (sao) on 2013-12-28
Changed in diodon:
status: Triaged → Fix Committed
Oliver Sauder (sao) on 2014-04-18
Changed in diodon:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers