Diodon - GTK+ Clipboard Manager

Diodon - missing scrollbars with large clipboard size

Reported by Rainer Rohde on 2013-03-19
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Diodon
Medium
Unassigned
diodon (Ubuntu)
Undecided
Unassigned

Bug Description

My Diodon clipboard size is set to 50, and when it gets full, it's missing the scroll-bars that allow you to scroll down all the way to the "Clear" option. I have to exit the history, and then enter it again. The second time around, I have the scroll-bars and I can scroll.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: diodon 1.0.2-0ubuntu1
ProcVersionSignature: Ubuntu 3.8.0-8.17-generic 3.8.0
Uname: Linux 3.8.0-8-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.9.1-0ubuntu1
Architecture: amd64
Date: Mon Mar 18 19:35:52 2013
EcryptfsInUse: Yes
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: diodon
UpgradeStatus: No upgrade log present (probably fresh install)

Rainer Rohde (rainer-rohde) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in diodon (Ubuntu):
status: New → Confirmed
Oliver Sauder (sao) wrote :

I could reproduce the issue. Will need to do some research how this can be prevented and the scrollbars appears the first time as well.

Thanks for reporting.

Changed in diodon:
status: New → Confirmed
importance: Undecided → Medium
Rainer Rohde (rainer-rohde) wrote :

Any time, Oliver. :) Thanks for the nice clipboard software.

Oliver Sauder (sao) wrote :

Just some update. This seems to be an new GTK issue. I could reproduce the issue with other applications as well.

See also here: http://stackoverflow.com/questions/14423971/what-is-the-correct-method-to-display-a-large-popup-menu

I am not sure tough what exactly is causing this. Will see what I can figure out.

Oliver Sauder (sao) wrote :

I have checked this issue again with Ubuntu 13.10 and cannot reproduce it anymore. Seems the Gtk issue is fixed.

Closing issue therefore for now. Please speak up though if you still see this issue with Ubuntu 13.10 or newer.

Changed in diodon:
status: Confirmed → Fix Released
Changed in diodon (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers