Diodon - GTK+ Clipboard Manager

Hotkey Ctrl+Alt+V does not work

Reported by markb on 2013-03-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Diodon
Undecided
Unassigned

Bug Description

It seems bug #1002475 has reoccurred? (seems I can't reopen that bug?). Refer https://bugs.launchpad.net/bugs/1002475.

I am running a current ubuntu 12.10 amd64 and diodon 1.0.2-0ubuntu0~quantal1 from the ppa and using gnome-shell. Diodon has always worked fine for me but recently(?) the hotkey ctrl+alt+v stopped working. Actually it works sometimes, but takes many attempts to work and is very inconsistent. Most presses of the hotkey seem to be ignored. Changing the hotkey to something else makes no difference.

Oliver Sauder (sao) wrote :

Hmm. Strange. Not sure whether this issue is related with #1002475 (although have the same effect). It also works without any problem on my computer having a similar same setup. So will need some more details to see what the issue could be.

Could you run following command on the terminal? To do so you have to close Diodon first.

G_MESSAGES_DEBUG=all /usr/bin/diodon > diodon-debug.txt 2>&1

Now open the indicator with the hotkey. Repeat so long until the indicator does not open anymore. Then terminate diodon and attach diodon-debug.txt here.

Thanks.

markb (mark-blakeney) wrote :

I don't see anything useful in the output other than that diodon seems to bind the keys ok.

[code]
** (diodon:4531): DEBUG: xml-clipboard-storage.vala:90: Read storage file /home/mark/.local/share/diodon/storage.xml
** (diodon:4531): DEBUG: keybinding-manager.vala:140: Unbinding key <Ctrl><Alt>V
** (diodon:4531): DEBUG: keybinding-manager.vala:98: Binding key <Ctrl><Alt>V
** (diodon:4531): DEBUG: keybinding-manager.vala:129: Successfully binded key <Ctrl><Alt>V
[/code]

If I press ctrl-alt-v very quickly then diodon will almost always pop up after the second press. If I wait a second or so between presses then diodon will never come up. The cursor always flashes though so something is seeing those key presses. Seems to occur equally in native gtk apps, qt apps, etc. I normally use gnome-shell but happens also in Unity.

I run Ubuntu 12.10 amd64 also in VirtualBox (i.e. Ubuntu 12.10 amd64 guest in same host) and there it works ok(!) - both in gnome shell and Unity. I run xorg edgers ppa in my host (which I guess could be related to this issue) so I installed it into the guest for a test but diodon still worked ok there.

markb (mark-blakeney) wrote :

I purged the xorg edgers ppa and now diodon works fine so close this bug if you see fit.

BTW, minor issue - when you press the hotkey repeated diodon scrolls through the selections allowing you to paste quickly. I would expect to be able to "quit" without action from this but there seems no way to do it? E.g. press hotkey + ESC somehow?

Oliver Sauder (sao) wrote :

OK. Closing this then.

Just as a hint about the hotkey:
Yes pressing the hotkey several times is a easy way to select an item in the menu (see http://esite.ch/2011/12/03/whats-new-on-the-diodon-front/ ). However when you open up the menu with the hotkey just directly press Escape and the menu will close. This also works when you use the hotkey only once, then the keyboard arrows (which does not choose the item automatically) and then Escape.

Changed in diodon:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers