Diodon - GTK+ Clipboard Manager

Periodically last copied item is not at the top of the menu

Reported by Xavier Guillot on 2012-11-05
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Diodon
Medium
Oliver Sauder

Bug Description

Hello,

Thanks a lot for the power- and useful program Diodon, which keeps constantly improving and is one of the most essential on Ubuntu.

There is a little "bug" - or unexpected behavior - that I'd like to report :

I have lots of entries in the history menu of Diodon, which allows to remember and select many old clipboards content.

When I do that and click on a row (except the first one), content is well copied (in the clipboard and on a document if it is a text), but the row remains at its initial position in the indicator menu.

I expect - if it is possible - the selection to "go back" on the top as first row, in order to see after what is the current clipboard.

I think it should be as, for example : if I re-select in a text the same words which were before on the history of Diodon, and re-copy them with Ctrl-C command (or Edit - Copy), here the row in Diodon menu is well moved to the top - not another row with same content is added, the entry just appears once in the first position.

Thanks in advance.

Related branches

Xavier Guillot (valeryan-24) wrote :

The same when I select an history entry from Diodon Unity lens.

But : I updated to last version (0.9.0), and I just noticed that sometimes the behavior was the one expected : selected entry goes to first row. Not always, most often it stays at the same place.

I'm trying to see when it occurs...

Xavier Guillot (valeryan-24) wrote :

OK, first experiment :

I restart computer, login (Ubuntu 12.10). Clipboard is empty, not Diodon history : many text items + 1 file entry

I open gedit.

From Diodon indicator menu, I select an entry (not the first one) : content is copied on gedit, row well goes to first place.

Then if I select other entries, text (or location of the file as text) are well written and each time the row selected goes to first place.

Then I close gedit, only the desktop is shown. I try again to select a row with a text entry in Diodon. Of course, nothing is copied on the desktop (it's not a file), content is copied on clipboard but row does not go to first place, it stays where it was.

After that, each time I select an history row, it does not go to the top anymore...

Oliver Sauder (sao) wrote :

Thanks for this bug report. It should definitely be the case that the current clipboard content is the item on the top.

I unfortunately could not reproduce this issue though on my computer even after following the steps you have described.

Maybe some debug result will get some more light to this. So can you close Diodon, open up a terminal and run following command:

G_MESSAGES_DEBUG=all /usr/bin/diodon > diodon_debug.txt 2>&1

Try to reproduce the issue. The first time the error appears quit Diodon again and attach the diodon_debug.txt file to this issue.

Thanks.

Xavier Guillot (valeryan-24) wrote :

Thanks for your answer.

OK, this time I'm on my home computer, Ubuntu Quantal 64 bits, Diodon last version from your daily ppa.

What I did : I had "Nightingale" and "gnome-session-propertie" in the history menu of Diodon

I copied "G_MESSAGES_DEBUG=all /usr/bin/diodon > diodon_debug.txt 2>&1"

then closed Diodon, and restarted it from terminal with this command.

Opened gedit.

Made Ctrl-V to paste G_MESSAGES_DEBUG=all /usr/bin/diodon > diodon_debug.txt 2>&1

Selected "gnome-session-properties" on Diodon menu, it was pasted in gedit and line went to first row.

Selected "Nightingale" on Diodon menu, it was pasted in gedit and line went to first row.

At this time I had on Diodon menu :
Nightingale
gnome-session-properties
G_MESSAGES_DEBUG=all /usr/bin/diodon > diodon_debug.txt 2>&1

Then I selected Firefox from Unity launcher, clicked with the mouse on the page, where there was no bar nor window to enter text.

Selected "gnome-session-properties" on Diodon menu, of course nothing pasted in Firefox, but "gnome-session-properties" did not move to first row on Diodon if I open the menu, it stayed at second place.

Closed Diodon.

Content was well copied to clipboard, as when I went back to gedit and Ctrl-V, it pasted "gnome-session-properties"

Last, when I restarted Diodon, without doing anything else, if I open the menu, now I had well "gnome-session-properties" on the first row... (see screenshot on next post)

gnome-session-properties
Nightingale
G_MESSAGES_DEBUG=all /usr/bin/diodon > diodon_debug.txt 2>&1

But it was not the case before.

I can reproduce it often : when I select from menu items that were just previously already pasted, menu does not change, until I restart Diodon, and there range is correct.

Xavier Guillot (valeryan-24) wrote :
Oliver Sauder (sao) wrote :

Hmm. OK still can't reproduce it.

However the error
LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent. seems to be a bit weird.

Will see whether I can get to the cause of this error message.

Oliver Sauder (sao) on 2012-12-17
Changed in diodon:
status: New → Confirmed
summary: - When selecting an old entry in the History Menu of Diodon, it does not
- mount to 1st row
+ Periodically last copied item is not at the top of the menu
Oliver Sauder (sao) wrote :

OK. Finally I can reproduce the issue. It seems a menu item does not get reordered to the top when it has been chosen twice.

I am still tackling though the issue what could cause this.

Changed in diodon:
importance: Undecided → Medium
assignee: nobody → Oliver Sauder (sao)
milestone: none → 1.0.0
Oliver Sauder (sao) wrote :

Hmm.... Interesting there is a Bug 785852 which causes the application indicator not to reorder its items.

So after finding this I have implemented a workaround this bug by simpling removing and adding the item.

This has been committed and should be able for testing in the daily ppa soon.

Please let me know whether this fixes your issue as well.

Changed in diodon:
status: Confirmed → Fix Committed
Xavier Guillot (valeryan-24) wrote :

Thanks a lot ! I'm glad you could reproduce the bug and identify with more precision when it happened.

OK, I tested since yesterday the last ppa update on my 2 computers, for the moment all seems corrected and works, selected item well goes to first row each time.

Oliver Sauder (sao) on 2013-01-01
Changed in diodon:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers