Spurious 'properties changed' line on incremental diffs

Bug #681885 reported by Guilherme Salgado on 2010-11-26
4
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Bazaar
Undecided
Unassigned
Difftacular
Medium
Unassigned
Launchpad itself
High
Unassigned

Bug Description

The incremental diff below r11984 on https://code.launchpad.net/~salgado/launchpad/expose-blueprints/+merge/41898 has tons of spurious lines for properties changed on directories/files.

Aaron Bentley (abentley) on 2010-11-26
tags: added: code-review
Changed in difftacular:
status: New → Triaged
Changed in launchpad-code:
status: New → Triaged
Changed in difftacular:
importance: Undecided → Medium
Changed in launchpad-code:
importance: Undecided → High
Aaron Bentley (abentley) wrote :

To reproduce with difftacular:

bzr branch lp:~salgado/launchpad/expose-blueprints
cd expose-blueprints
bzr diff-ignore-branches -r 11981..11984 ../stable/

stable @ revno 11985

Aaron Bentley (abentley) wrote :

The root cause appears to be a disagreement between RevisionTree.is_executable and RevisionTree._comparison data about directories and symlinks: is_executable says their value is False, is_executable says their value is None.

Aaron Bentley (abentley) wrote :

That is, is_executable says their value is None.

Vincent Ladeuil (vila) on 2010-12-02
Changed in bzr:
milestone: none → 2.2.3
status: New → Fix Released
Robert Collins (lifeless) wrote :

IIUC this is now fixed with the bzr fix, and we're running that (or newer) bzr.

Changed in launchpad:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers