OpenERP addons by Didotech.com

Metel don't import product

Reported by Carlo - Didotech.com on 2011-09-15
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
OpenERP Addons by Didotech.com
Critical
Marco-jem

Bug Description

If i import a metel pricelist it don't work

Changed in didotech-openerp-addons:
assignee: nobody → Marco-jem (marco-jem)
Marco-jem (marco-jem) wrote :

Please add some explanation on how to reproduce this issue so I can fix it ....as stated mane and many and MANY times if is not sufficient to say "Hey this thing does not work anymore" to ask someone to fix it!!!!

Changed in didotech-openerp-addons:
importance: Undecided → High
Marco-jem (marco-jem) wrote :

OK, the previous comment was a joke :D
I'm uploading e new version of Metel module (as an attachment to this comment) that should fix the problem, but it need to be verified!!!!

PS Remember me to create a branch and a serie for Metel!

Changed in didotech-openerp-addons:
status: New → In Progress
Carlo - Didotech.com (iw3hxn) wrote :

Test, and don't import.

Carlo - Didotech.com (iw3hxn) wrote :

for use this importer go to :
Purchase
     -> Configuration
                 -> Pricelist

ed go to wizard "Import Metel Pricelist file

Changed in didotech-openerp-addons:
importance: High → Critical
Marco-jem (marco-jem) wrote :

Problem solved by deleting .pyc files from previous versions of Metel Module

Changed in didotech-openerp-addons:
status: In Progress → Fix Committed
Marco-jem (marco-jem) on 2011-09-19
Changed in didotech-openerp-addons:
status: Fix Committed → Fix Released
Lapresa (lapresa) wrote :

I tried with included ABB pricelist sample: NO success!

start an endless process,without any result

Lapresa (lapresa) wrote :
Download full text (71.9 KiB)

provato con il file intero scaricato da ABB

<type 'exceptions.MemoryError'> Python 2.7.2+: /usr/bin/python
Fri Dec 16 23:28:22 2011
A problem occurred in a Python script. Here is the sequence of function calls leading up to the error, in the order they occurred.
 /usr/lib/pymodules/python2.7/cherrypy/_cprequest.py in respond(self=<cherrypy._cprequest.Request object>, path_info='/openerp/form/edit')
    604 if self.handler:
    605 self.stage = 'handler'
=> 606 cherrypy.response.body = self.handler()
    607
    608 self.stage = 'before_finalize'
global cherrypy = <module 'cherrypy' from '/usr/lib/pymodules/python2.7/cherrypy/__init__.pyc'>, cherrypy.response = <cherrypy._ThreadLocalProxy object>, cherrypy.response.body = [], self = <cherrypy._cprequest.Request object>, self.handler = <cherrypy._cpdispatch.LateParamPageHandler object>
 /usr/lib/pymodules/python2.7/cherrypy/_cpdispatch.py in __call__(self=<cherrypy._cpdispatch.LateParamPageHandler object>)
     23 def __call__(self):
     24 try:
=> 25 return self.callable(*self.args, **self.kwargs)
     26 except TypeError, x:
     27 test_callable_spec(self.callable, self.args, self.kwargs)
self = <cherrypy._cpdispatch.LateParamPageHandler object>, self.callable = <bound method Root.default of <openobject.controllers._root.Root object>>, self.args = ('openerp', 'form', 'edit'), self.kwargs = {'context': "{'lang': u'it_IT', 'active_ids': [632], 'tz': u'...eb', 'project_id': False, 'department_id': False}", 'count': '4', 'domain': '[]', 'filter_domain': '[]', 'id': '4', 'ids': '[1, 2, 3, 4]', 'limit': '20', 'model': 'product.metel.import', 'notebook_tab': '0', 'offset': '0', ...}
 /opt/openerp/web/openobject/tools/_expose.py in func_wrapper(*args=(<openobject.controllers._root.Root object>, 'openerp', 'form', 'edit'), **kw={'context': "{'lang': u'it_IT', 'active_ids': [632], 'tz': u'...eb', 'project_id': False, 'department_id': False}", 'count': '4', 'domain': '[]', 'filter_domain': '[]', 'id': '4', 'ids': '[1, 2, 3, 4]', 'limit': '20', 'model': 'product.metel.import', 'notebook_tab': '0', 'offset': '0', ...})
    180 raise cherrypy.HTTPError(405)
    181
=> 182 res = func(*args, **kw)
    183 if format == 'json' or (allow_json and 'allow_json' in cherrypy.request.params):
    184 cherrypy.response.headers['Content-Type'] = 'text/javascript'
global res = '/opt/openerp/web/addons/view_graph/widgets/templates/graph.mako', func = <function default>, args = (<openobject.controllers._root.Root object>, 'openerp', 'form', 'edit'), kw = {'context': "{'lang': u'it_IT', 'active_ids': [632], 'tz': u'...eb', 'project_id': False, 'department_id': False}", 'count': '4', 'domain': '[]', 'filter_domain': '[]', 'id': '4', 'ids': '[1, 2, 3, 4]', 'limit': '20', 'model': 'product.metel.import', 'notebook_tab': '0', 'offset': '0', ...}
 /opt/openerp/web/openobject/controllers/_root.py in default(self=<openobject.controllers._root.Root object>, *args=('openerp', 'form', 'edit'), **kw={'context': "{'la...

Marco-jem (marco-jem) on 2011-12-17
Changed in didotech-openerp-addons:
status: Fix Released → New
status: New → In Progress
Marco-jem (marco-jem) wrote :

Hello Lapresa!

I just tested the module with the test data file included in the repository and it work without problems, I'm sorry but cannot reproduce the problem, also it seems something concerning the web interface, not the module itself.
Maybe there are to much rows of data to be shown in the preview form and so something went wrong during the generation of the web page ....but for now I can tell nothing.

To understand what the problem is I need more informations:

- Could you please specify what version of OpenERP are you using?
  (please write the complete version number, not just OpenERP 6 thanks!)

- The stacktrace you posted here is from OpenERP Server of from OpenERP Web Client?

- Could you please post the Metel file you used to test the module?
  (I will not download the one available from ABB because I want exactly the same file you used to run the test)

Thank you :)

Changed in didotech-openerp-addons:
status: In Progress → Incomplete
Sergio Corato (icsergio) on 2013-11-16
Changed in didotech-openerp-addons:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers